I've been troubleshooting an intermittent blue screen on a newly built system, no overclocking-

ASRock Z75 Pro3 (w/ latest Bios 1.4 and patches)
OCZ-Agility3 240Gb (Firmware 2.22)
Intel i5-3470
G.SKILL Ripjaws 8GB (2 x 4GB) DDR3 SDRAM DDR3 1600
EVGA GT 430
Win 7 Pro 64bit

The problem seems more likely on startup or waking from sleep, but it has happened at other times too.The code:

Bugcheck code: 0xF4 (0x3, 0xFFFFFA80069F5320, 0xFFFFFA80069F5600, 0xFFFFF80003396510

things I've tried most recently:

  • confirmed that the Bios is set to AHCI for the SSD
  • set Bios DRAM to XMP 1.2 (DDRs-1600 9-9-9-24 1.50V); previously I've also set to Auto and set DRAM voltage to 1.500V
  • memtest86+ v4.20 passed too- 7 runs with both sticks, a couple runs with single sticks
  • I suspected the SSD and sent it back to OCZ for testing; they've tested it and it passed all their tests
  • After I received the drive back I installed Win 7 fresh - before I even had a chance to load any additional drivers or windows updates it has crashed with a blue screen twice


Before the Win7 reinstall:
  • tried several different SSD driver options (in assoc with OCZ support)
  • I've changed the power settings so the hard drive doesn't go to sleep
  • Win 7 was fully updated, and every driver was up to date too
  • tried the SSD in the other SataIII port


any ideas?