Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock 990FX Extreme 4 freezes on b4/ external HDD issue?




  1. #1
    Mattrock is offline Junior Member
    Join Date
    Oct 2012
    Location
    Binghamton NY
    Posts
    1

    Question ASRock 990FX Extreme 4 freezes on b4/ external HDD issue?

    So last night I turn my PC off, as I do every night. Normally the shutdown procedure takes all of a minute, but last night, it took nearly 15 minutes to shut down. I thought it was strange, but figured it was installing updates or something. But this morning, I went to power up my PC, and now it won't load past the ASRock screen. It freezes, and I get a little "b4" in the lower-right corner, and another on the LED on the mobo. My keyboard and mouse light up like they're doing something, but then nothing happens when I tap F2 to enter the BIOS (I can't do anything, actually); power is getting to my peripherals (keyboard/ mouse/ Saitek X52) but signals aren't getting out. I pressed the Clear CMOS button on the mobo, but it didn't change anything.

    I cracked open my trusty mobo manual, and the Dr. Debug code (that "b4" it's reporting) is apparently something about "USB hot plug." So I unplugged all of my USB devices, and now it's posting fine. I'm guessing this must be an issue with my external HDD; like my PC is trying to read off of it or something? I went into the BIOS and checked, but it doesn't look like the HDD is in the list of boot devices. Very strange. I'd rather not have to disconnect my external each and every time I power on my PC. Any idea how I might fix this issue?

    I should also note that this randomly started happening today. My PC was running fine for two weeks prior to this. I made no alterations whatsoever to the external drive; I haven't even accessed it in three or four days. Last night I ran the full gauntlet of security and maintenance stuff; ESET Smart Security 5, then CCleaner, then Advanced Systemcare (free version), and there were no problems found or red flags raised, and my registry was clean and required no maintenance. So I'm guessing that didn't affect anything, but eh, mentioning it anyway.

    Detailed system specs are below. I'm including everything, all of my USB devices as well, because hey, you never know...

    Mobo: ASRock 990FX Extreme4 (BIOS version 1.50)
    CPU: AMD FX-8150 (8-core 3.6 GHz Zambezi/ "Bulldozer") (air-cooling, no overclock)
    RAM: G.Skill Sniper series 16 GB 1866 (shows as 1600 in my BIOS though... another problem for another day)
    Video: Sapphire HD 6950 OC Edition 256-bit 2 GB (model # 11188-22-20G)
    Sound: ASUS Xonar D1 card/ HP 2.1 speakers
    OS: Windows 7 Home Premium 64-bit
    Drives: Kingston SSDNow V200 series 256 GB SSD, 2x Western Digital Caviar Green 2 TB HDD's, LG Blu-Ray reader, LG DVD-R
    USB: Western Digital Elements 2.5 TB external HDD, Logitech G510 keyboard, Logitech G500 mouse, Saitek X52 Flight Control System
    Last edited by Mattrock; 10-09-2012 at 01:46 AM.

  2. #2
    dunnman99 is offline Junior Member
    Join Date
    Oct 2012
    Location
    Guam, Where America's Day Begins
    Posts
    2

    Default Re: ASRock 990FX Extreme 4 freezes on b4/ external HDD issue?

    Hello,

    New here, but I just installed my new M/B as well and had the same issue.

    I think you are correct as when I got into the BIOS with my USB's attached, it started listing them in the removable bootable devices and depending upon how many items you have- your BIOS needs to scan each one of them...Depending upon the speed and capacity of your USB drives may delay your shutdown or boot.

    I did walk away while the B4 was posted in the bottom right and came back 15 minutes later and guess what...booted. The issue is that you don't want to take 15 minutes to boot or shutdown.

    One of the issues is that your USB does not have an MBR, and the BIOS hangs on that.

    Best way....not the most convenient..shut down your attached USB drives before shutdown, and power them up once your OS is up and running. Tried this and boot and shutdown times are quick..one issue is that one of my USB 3.0 externals has a 50/50 as useable when I power it up..An unplug and plug back in solves the issue everytime though.

    dunnman99@yahoo.com

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •