I'm trying the following configuration without success and I was wondering if I'm overlooking anything:

MOBO: Refurbished ASRock 939NF4G-VSTA
CPU: AMD 64 x2 4600+ Core Stepping E6
BIOS:AMI Legal BIOS 4MB
Video: Integrated NV44 graphics DX9.0 VGA and (PNY Verto FX5200)
RAM: Low density DDR1 1 GB 400 Mhz RAM (tried 2 other 1GB sticks 333Mhz and 400 Mhz)
PSU: Antec BP-350 (350 watts PSU)
CPU Cooler: Thermaltake CL-P0200 (TDP 120 watts)

All the fans are going but I'm getting no video signal to my monitor from the mobo and I 'm getting 2 short beeps (parity check error?). Although this beep code is associated with RAM error, I also read that it can be the mobo or something else. I did the "benchmark" test and no success. I cleared the bios several times, re-seated the RAM(s) and CPU several times with a brand new CPU and PSU.

I highly doubt that all 3 RAM sticks I tried are faulty and I'm beginning to suspect that the CPU might not be compatible with the motherboard because of the core stepping version, although different sources have conflicting claims on this. Please, can someone point me in the right direction? I already talked to the mobo dealer and they don't have any conclusive answers either.

Thank you for your help!