Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0




  1. #1
    lbdesign is offline Junior Member
    Join Date
    Oct 2012
    Location
    Serbia
    Posts
    5

    Default h77 pro4/MVP and Radeon 7750 with i5-3550 on PCI Express 3.0 shows no picture

    I have h77 pro4/MVP, i5-3550 and Radeon 7750 ultimate from Sapphire. When I insert VGA in to 3.0 Express slot there are no system info about vga card (in system browser - bios), also a have no picture on my monitor. When I insert VGA in to PCI Express 2.0 I have info in BIOS and picture on my monitor. Try VGA card in PCI 2.0 and my frame rate and graphics are good so I believe that card is OK without defect. What can be the problem? As I know, i5-3550 and Radeon 7750 are all PCI 3.0 Express compatible.

    Latest: test my old PCI express 2.0 ATI in both slots and it`s working. Is there chance of some BIOS Firmware incompatibility or some of my hardware (motherboard or VGA ) have defect?

    Final: After sending MB in service they give me possibility to add some money for ASRock Z77 Pro4 where same Sapphire 7750 works in PCIE3.0. The problem was in the h77 pro4/MVP MB.
    Last edited by lbdesign; 11-13-2012 at 12:57 AM.

  2. #2
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    Quote Originally Posted by lbdesign View Post
    can you point me on some thread with 7750 or Sapphire PCI3 compatibility?
    I'm at work right now, so i'll take a deeper look again later, but I found last week which I think it might have been a review on newegg, that said that the user RMA'd his video card and the replacement worked like a charm. I wish I saved that link. :(
    But I do know found it via google. Seems my google-fu is not strong today lol

    I for sure know my ASRock board has no problems with PCIe 3 as I'm running on it right now :) I have a z77 OC Formula with an Nvidia(evga) gtx 680.

    Here is another thread here I participated on. The OP tried a few things and came to the same conclusion that it "seemed" like his video card. He has not yet responded to indicate if that solved it.

  3. #3
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    Here is the user from this forum that had the same issue and replaced his card. see specifically post #22 where they report back. I still have yet to find the user from another forum with the same issue. I know I saw it... just having troubles finding it again. Hopefully it didn't get pulled.


    Syn

  4. #4
    TTkiraTT is offline Junior Member
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    14

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    Quote Originally Posted by synack View Post
    Here is the user from this forum that had the same issue and replaced his card. see specifically post #22 where they report back. I still have yet to find the user from another forum with the same issue. I know I saw it... just having troubles finding it again. Hopefully it didn't get pulled.


    Syn
    I'm having the same issue but with my GTX 570 Geforce computer was working fine just fine then suddenly its like no responde from the PCI express slot tried a different video card GTS 250 and still nothing... computer was working perefec with that video card for almost a year and suddenly no more pci :S onboard is working just onboard i thought could be the BIOS but i dnt want to take risks :S

  5. #5
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    As I responded in the other thread, this is not the same issue. the two threads you took over deal with compatibility issues between certain video cards and certain motherboards.
    If its been working for a year, you would not just get a compatibility issue all of a sudden. something broke somewhere.
    we can try and help, however we need more info about the details. it would be better if you started a new thread as your issue is unrelated to the two you have posted in.

  6. #6
    TTkiraTT is offline Junior Member
    Join Date
    Jan 2013
    Location
    Argentina
    Posts
    14

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    Quote Originally Posted by synack View Post
    As I responded in the other thread, this is not the same issue. the two threads you took over deal with compatibility issues between certain video cards and certain motherboards.
    If its been working for a year, you would not just get a compatibility issue all of a sudden. something broke somewhere.
    we can try and help, however we need more info about the details. it would be better if you started a new thread as your issue is unrelated to the two you have posted in.
    Ok sure pls tell me what u want me to post.... i already did it and nobody replied.... :S tell me what u need form my pc spects ill give them.. i know its pointless that actually stop working like that.. weird never happened to me before in my life its the first time.. Felling sad actually :S

  7. #7
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: h77 pro4/MVP and Radeon 7750 on PCI Express 3.0

    I didn't even see your other thread. I have posted there now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •