Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: System Time not saving in BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc




  1. #1
    eiger3970 is offline Junior Member
    Join Date
    Aug 2012
    Location
    Australia
    Posts
    4

    Default System Time not saving in BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc

    Hi TweakTown Forums,
    well it seems another problem has arisen.
    The System Time keeps changing which means I cannot set the server to turn on automatically at 08:00.
    I have replaced the MOBO G41M-VS3 with 3 CR2032 batteries (2 from cheap shop, 1 from expensive Energiser) and this does not fix the MOBO's BIOS saving the System Time.

    Process:
    1. Boot computer.

    2. Press Delete button every 1/2 second.

    3. BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc opens and change System Time to current time.

    4. F10 and Ok to save and exit BIOS settings. (Computer then boots up Proxmox).

    5. In Proxmox root@proxmox: Date is entered and the correct time shows.

    6. Shutdown Proxmox root@proxmox: shutdown -h -P now.

    7. Reboot computer (AND SOMETIMES THIS BOOT ERROR APPEARS:
    done.
    activating swap...done
    checking root file system...fsck from util-linux-ng 2.17.2
    dev/mapper/pve-root: Superblock last mount time is in the future.
    (by less than a day, probably due to the hardware clock being incorrectly set) FIXED.
    dev/mapper/pve-root: Superblock last write time is in the future.
    (by less than a day, probably due to the hardware clock being incrrectly set). FIXED.
    dev/mapper/pve-root: clean, 39494/6291456 files, 1978311/25165823 blocks
    done.
    cleaning up ifupdown....
    setting up networking....
    loading kernel modules...done.
    Setting up LVM (...and so on...).

    and then Proxmox still shows the correct time.

    8. Reboot computer and go into BIOS and the incorrect System Time shows 99% of the time?

    9. Then reboot again into Proxmox with wrong BIOS System Time and correct time shows???

    This is no good as the automatic boot won't work without the correct BIOS System Time.

    I am rechecking latest BIOS firmware, however I have already flashed the BIOS a few times on this and other MOBOs and continue to have the same issue.

  2. #2
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: System Time not saving in BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc

    Time is a funny thing with linux.

    Check your timezone settings. I'm not sure about proxmox, but most linux distros have timezone info in /etc/timezone.

  3. #3
    najiro is offline Junior Member
    Join Date
    Aug 2012
    Location
    Davao City, Philippines
    Posts
    33

    Default Re: System Time not saving in BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc

    I think your CMOS battery is dead. Try replacing it with a new one.

  4. #4
    synack's Avatar
    synack is offline Member
    Join Date
    Oct 2012
    Location
    Ontario, Canada
    Posts
    265

    Default Re: System Time not saving in BIOS G41M-VS3 P1.20 v02.67c American Megatrends Inc

    Further note: it's also possible that your proxmox is setting the bios hardware clock to the UTC time. You can then either do the math in your head yourself for calculating the "on time" or google around and find out what settings you need to change to set your linux to use BIOS time as "localtime"

    I'm not familiar with proxmox but give this a try:

    Proxmox seems to be based on Debian, so also check /etc/default/rcS for a line called "utc=..." and make sure it says no.
    You should also have a command tzselect (located in /usr/bin/) that allows simple timezone selection.

    Once both those are configured, make sure you have the correct time in proxmox (run the date command to verify)
    Then reboot. This should cause your linux to write the localtime into the BIOS.
    Enter BIOS and confirm. if it didn't try resetting it in bios again.

    if you get file system errors about "future time" on boot up, you will have to ignore them.

Thread Information

Users Browsing this Thread

There are currently 3 users browsing this thread. (0 members and 3 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •