Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: asRock z77 extreme 3 not seeing all RAM




  1. #1
    helpame is offline Junior Member
    Join Date
    Oct 2012
    Location
    sd
    Posts
    32

    Default asRock z77 extreme 3 not seeing all RAM

    I had two different issues on one post one of the issues has been resolved but this one still remains

    Mobo = ASRock Z77 Extreme3 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
    RAM = Patriot Viper Xtreme Series, Division 2 Edition 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC3 19200) Desktop Memory ... x2 (16gigs)
    CPU = Intel Core i7-2600K Sandy Bridge 3.4GHz (3.8GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics ...
    GPU = EVGA 02G-P4-2680-KR GeForce GTX 680 2GB 256-bit GDDR5 PCI Express 3.0 x16 HDCP Ready SLI Support Video Card
    HD = Western Digital WD VelociRaptor WD2500HHTZ 250GB 10000 RPM SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive
    PSU = Rosewill Stallion Series RD700 700W ATX12V V2.3 SLI Ready CrossFire Ready Power Supply
    OS = windows 7 home 64 bit

    I have marked my dual channel sets 11-12 and 21-22 i've individually have pulled all RAM out and inserted each one into each different slot they all work, ive tried the sets in both a1 and b1 and a2 and b2 slots they all work only when i have all 4 sets in a2 and b2 slots do not have RAM showing in my bios nor does the OS see the additional 8 Gigs. Thats all i got so far so feel free to give me suggestions it would be greatly appreciated.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: asRock z77 extreme 3 not seeing all RAM

    1. A very new board, all of one BIOS/UEFI version available. A future BIOS may support all your memory.

    2. The only Patriot memory listed in the Memory Support List that is closest in speed to yours is: PXD38G1866ELK.

    3. Are you setting your memory to it's full, 2400 speed? If so, don't, let it default to whatever speed, or set it to 1333 or 1600 when all of it is installed.

    4. With two DIMMs installed at a time, run CPU-Z, and take screen shots of the SPD and Memory tabs. Compare all the specs to be certain that the two separate kits you have match specs. I have seen it happen in the past, where two "identical" kits made at different times had different speed and timing settings data, which when combined can cause odd results.

  3. #3
    helpame is offline Junior Member
    Join Date
    Oct 2012
    Location
    sd
    Posts
    32

    Default Re: asRock z77 extreme 3 not seeing all RAM

    Quote Originally Posted by parsec View Post
    1. A very new board, all of one BIOS/UEFI version available. A future BIOS may support all your memory.

    2. The only Patriot memory listed in the Memory Support List that is closest in speed to yours is: PXD38G1866ELK.

    3. Are you setting your memory to it's full, 2400 speed? If so, don't, let it default to whatever speed, or set it to 1333 or 1600 when all of it is installed.

    4. With two DIMMs installed at a time, run CPU-Z, and take screen shots of the SPD and Memory tabs. Compare all the specs to be certain that the two separate kits you have match specs. I have seen it happen in the past, where two "identical" kits made at different times had different speed and timing settings data, which when combined can cause odd results.
    no i let all the DIMM under bios be set as auto i think its reading 1333 or 1066 ill check out cpu-z and report back i guess thanks for the hlp man

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •