Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Enabling Turbo Mode - Z77 Extreme4 and i7-3770K




  1. #1

    Default Solved. Enabling Turbo Mode - Z77 Extreme4 and i7-3770K

    Running the latest BIOS 2.4 10/25/12.

    Having an issue getting Turbo enabled without enabling Advanced Turbo 30. If Advanced Turbo 30 is not enabled, it does not seem to engage the turbo, and won't go above 3.5GHz when I start up Prime95 or IBT. I have Turbo itself enabled in the BIOS, but, have not added any Additional Turbo Voltage.
    Tried CPU Cores set to Auto and All Cores.
    Thoughts?
    Last edited by Capt Proton; 11-12-2012 at 01:05 AM.

  2. #2

    Default Re: Enabling Turbo Mode - Z77 Extreme4 and i7-3770K

    Never mind. Works.
    i7 3770K, 47X100= 4.7GHz at 1.33V, ASROCK Z77 Extreme4, 2 X 4GB Patriot Viper Black Maba DDR3 1600, GTX 590, 2 X Corsair Force 3 120GB SSDs in RAID 0, Barracuda SATA 7200.10 500GB, Barracuda SATA 7200.11 1000GB Back Ups, OCZ ZX 1250W, Z-5500s, LG Blu Ray Player/DVD Burner, Koolance CTR-CD12 Fan/Pump Controller, Windows 7 X64 Professional, HAF X. Vision Quest 24" WS LCD, Optoma H66 Projector
    Cooling: Thermochill PA120.2 GT AP15 in push, DDC 3.25/XSPC Res top, Apogee Xt Extreme, XSPC Razor, Coolgate CG-240 Swiftech Helix in push/pull, MCP35X.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •