Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock Z77 Pro3 no display




  1. #1
    Join Date
    Nov 2012
    Location
    Denmark
    Posts
    1

    Default ASRock Z77 Pro3 no display

    Hi, just bought a few parts and one of them is ASRock Z77 Pro3. Everything should be connected correctly. When I start up the system, nothing gets displayed on the monitor. Currently using the onboard but have also tried with an older Nvidia GForce card, that works in another computer.
    When I startup, the fans speed up, but nothing else happends. Not sure if there should be any biip sounds during startup? There is light in the keyboard, but no matter how many keys I hit, still no sound.
    Have tried with another powersupply, that works in another computer. 500W both of them. Currently using Corsair Value Select 8 GB single RAM module, and have tried it in all slots.

    Any ideas?

    Cannot say the bios version, since i havent been in the bios yet.

  2. #2
    Join Date
    Nov 2008
    Location
    San Francisco
    Posts
    5

    Default Re: ASRock Z77 Pro3 no display

    Same problem, different board-Extreme4- See my post (New System-No Video) of 4 miinutes ago. Not hi-jacking your thread, just replying to yours so that I'll be notified of any replys you get. Feel free to reply to mine for same reason.
    Zalophus
    Abit 35Pro-Bios 17; E8500-CO@4.1Ghz; Xigmatek S-1283; Mushkin Ascent XP 1066-2X2GB; XFX 8600GT; Corsair HX620; Antec 900; Vista Ultimate x64

    ASUS P8Z77-V LE Plus; 3570K;CM 212 Plus;Corsair Vengance 1866 2x8GB;Seasonic 750W;Samsung 830-128GB;WD Black 1TB;WD Blue-1TB;Fractal Arc Midi;Win7 Pro x64

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •