Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: USB 2.0 rear ports won't work with USB hub




  1. #1
    Join Date
    Nov 2012
    Location
    Germany
    Posts
    1

    Default USB 2.0 rear ports won't work with USB hub

    Hi,

    I have just purchased an Asrock Z77 Extreme11 Mainboard and set up my computer. Most of the things work quite well - however, I have got one big issue with the two USB 2.0 ports on the backpanel. The work if I plug in a usb device like my printer or a usb stick. They don't work as soon as I plug in a USB 4-Ports Hub without external power supply. I use for example one of these: Slim Spider USB Hub-DA-70216 | DIGITUS

    When I plug it in, nothing happens in Windows, it does not get recognized. It even does not forward the power because the led of my USB stick won't light up either. Then I connected the Hub to aUsb 3.0 port and everything worked fine.
    So that must be an issue with the USB 2.0 ports - do you any idea? Is the board defective? (Both USB 2.0 ports on the back show the same behavior and I cannot use a USB 3.0 port as I need them for other things. :( )

    Appreciate your answers...
    Thanks!

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: USB 2.0 rear ports won't work with USB hub

    I doubt that there is something wrong with the USB 2.0 ports. Did you check Device Manager, under USB controllers, to find your USB hub? USB hubs are usually not recognized the same way that USB flash drives are.

    A USB 2.0 port can only supply between 0.1A to 0.5A of 5V power, so if that is shared among four ports, there's not much power available to each one. USB hubs have protection circuits to manage the power draw, so the mother board USB port circuit is not damaged. The extra power supply to the hub is there for these reasons.

    USB 3.0 ports can supply up to 0.9A of 5V power, or more depending on the devices configuration. That is why your hub worked better when connected to the USB 3.0 port.

    The USB hubs I use act the same way yours does, they don't seem to work unless the extra power supply is connected.

  3. #3
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: USB 2.0 rear ports won't work with USB hub

    Dang, you've used all 8 rear USB 3.0 positions huh?

    That Slim Spider you link to, it has a 2.5mm socket for external power so I'm guessing Digitus/Assmann would have a external power brick or possibly USB A Male to 2.5mm cable that would provide the needed auxiliary power to it. But IMO 2.5mm plugs aren't hardy/sturdy enough to take repeated stresses. Worse, considering where it looks like it plugs into on the Spider hub you linked, it would stick out a 90deg angle to the casing, inviting even more undue stress.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •