Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 7 123 ... LastLast
Results 1 to 10 of 70

Thread: Asrock you have lost a customer for good BYE!




  1. #1
    shankly1985 is offline Junior Member
    Join Date
    Nov 2012
    Location
    United Kingdom
    Posts
    35

    Default Asrock you have lost a customer for good BYE!

    I am shocked at the lack of customer support you guys have done for windows 8 on the Z68 boards not even One year old and you lazy sods not even supporting. O but your new z77 support it WELL Guess what We not buying into that trick. I have emailed you couple weeks ago asking where is the Windows 8 support and I have had zero reply and I was very nice when I sent it.

    Rant over from one P'ed off customer.

    One last thing, it really is such a shame also your Board are superb quality. Wish I could also say that about your support.

  2. #2
    Join Date
    Jul 2011
    Location
    Poland
    Posts
    9

    Default Re: Asrock you have lost a customer for good BYE!

    I feel the same, my Z68 Extreme4 Gen3 board doesn't support Win 8 fast boot in UEFI, drivers from win 7 work in win 8 but it's not enough and I don't need to buy new Z77 mobo just for that, new intel platform is on the way so what's the point in it ?

    Let's just compare other vendors' win 8 support in Z68 boards ! :

    Asus :

    Z68 boards are not certified but at least got it's drivers

    Gigabyte

    Drivers available, don't know if utra fast boot will work on it

    Microstar

    Drivers available, almost sure that utra fast boot will not work on it

    Asrock


    No drivers, no utra fast boot

    Thank you, and good luck for finding new customers, I know it's all about money and cerificates cost but if you don't care then we also.

  3. #3
    shankly1985 is offline Junior Member
    Join Date
    Nov 2012
    Location
    United Kingdom
    Posts
    35

    Default Re: Asrock you have lost a customer for good BYE!

    So true, Asrock just want people to spend on there z77 forget about there z68 customers.

  4. #4
    zoomee is offline Junior Member
    Join Date
    Dec 2012
    Location
    UK
    Posts
    1

    Default Re: Asrock you have lost a customer for good BYE!

    I'm in the same boat. Dissapointed at two things actually which have made me think I will never buy an Asrock motherboard again:

    A)- USB3 support is rubbish - The ports have always been inconsistently slow and now their at the point they stop working sometimes.
    B)- Lack of Windows 8 support on such a new product is abysmal. Even Asus (who I rank amongst the worst at updates for older products still have brought out Windows 8 support!!!!)


  5. #5
    shankly1985 is offline Junior Member
    Join Date
    Nov 2012
    Location
    United Kingdom
    Posts
    35

    Default Re: Asrock you have lost a customer for good BYE!

    Quote Originally Posted by zoomee View Post
    I'm in the same boat. Dissapointed at two things actually which have made me think I will never buy an Asrock motherboard again:

    A)- USB3 support is rubbish - The ports have always been inconsistently slow and now their at the point they stop working sometimes.
    B)- Lack of Windows 8 support on such a new product is abysmal. Even Asus (who I rank amongst the worst at updates for older products still have brought out Windows 8 support!!!!)

    So true, have you seen how long they have had them drivers in Beta? Do Asrock have a gang of noobs working for them, that would answer why we cant even get Windows 8 drivers. Have you also seen how Outdated there Windows 7 drivers are.

    Asrock Poor Service.

  6. #6
    WillyG's Avatar
    WillyG is offline Junior Member
    Join Date
    Dec 2011
    Location
    Phoenix
    Posts
    22

    Default Re: Asrock you have lost a customer for good BYE!

    Quote Originally Posted by shankly1985 View Post
    So true, have you seen how long they have had them drivers in Beta? Do Asrock have a gang of noobs working for them, that would answer why we cant even get Windows 8 drivers. Have you also seen how Outdated there Windows 7 drivers are.

    Asrock Poor Service.

    Windows 8 sucks monkey spit. You want to use it, WHY? You sure must not be a gamer.

  7. #7
    shankly1985 is offline Junior Member
    Join Date
    Nov 2012
    Location
    United Kingdom
    Posts
    35

    Default Re: Asrock you have lost a customer for good BYE!

    Quote Originally Posted by WillyG View Post
    Windows 8 sucks monkey spit. You want to use it, WHY? You sure must not be a gamer.
    Yes I am a gamer, and no windows 8 rocks and just so you know my gaming performance has increased since using windows 8 and my heaven 3.0 benchmark has shown that to be true.
    Windows 8 is all about speed and it doesn't let down one single bit so much faster than windows 7.
    You get everything that is great about windows 7 made even better, with the speed and the new superb start menu have everything I need in one single place.

  8. #8
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Asrock you have lost a customer for good BYE!

    Ya know you really should unsubscribe from this thread so that you're not lured back here after saying "BYE"
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  9. #9
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Cool Re: Asrock you have lost a customer for good BYE!

    food for thought:
    • Never argue with a fool, onlookers may not be able to tell the difference.
    • Never Argue With A Fool They Will Drag You Down To Their Level, Then Beat You With Experience!

    Much as I'm tempted to hit the BAN button, I ignore ignorant posts.
    Last edited by profJim; 12-10-2012 at 12:58 PM.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  10. #10
    shankly1985 is offline Junior Member
    Join Date
    Nov 2012
    Location
    United Kingdom
    Posts
    35

    Default Re: Asrock you have lost a customer for good BYE!

    What's with the Hate? I say good bye meaning I will never buy an Asrock product again. What am I still using? Yes you guessed it
    Am here trying to get us better support and yet am the bad person? This issue dont just start because of No Windows 8 Drivers this been happening for months and we still have well out dated Windows 7 Drivers.

    Windows 7 Drivers
    ChipSet Latest 9.​3.​0.​1026 - Asrock Site 9.2.0.1021
    Audio Realtek Latest 2.70 - Asrock Site 2.62
    Broadcom Lan driver Latest 15.4.0.9 - Asrock Site 14.6.4.2
    List go's on

    Windows 8 Drivers
    Asrock Site None

    So dont make it out Like am the bad person here, the Support Asrock has shown us over the past Year with Drivers is shocking. On the good side they have released BIOS updates and there boards are very well built. But why Zero updated drivers?

Page 1 of 7 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •