I have this retarded issue that i cannot get through no matter what i do

When i pop my gpu into asus p8b75-m le (pcie 3.0/2.0 x16) slot and power on ze machine , charge is given , fans be spinnin' but no image is supplied to the monitor . I have played with all possible settings in the BIOS via Onboard crap graphics le intel , ofc i updated it to latests firmware blah bla bla . i quadruple checked to make sure that power cords were connected in an orderly manner in the GPU.

Almost gave up but no , i had my Newton and the apple moment where i decided to plug my GPU into the slower pcie 2.0 x4 slot which runs at an embarrassingly slow speed for a mid-high end GPU like 670. And viola ! It worked , i finally got an image to my monitor. Did a few front flips out of happiness , entered windows 7 , did few benchmarks and the smile left my face once again. Very unacceptable performance for a 300$ card.

But no i didn't give up that easy. By that time i was pretty much convinced that my mobo was faulty or at least some part of it. I ran down to a local pc part dealer and bought a shiny new ASRock Z77 Extreme4-M which supports SLI. Plugged out everything from old asus mobo into ASRock mobo , GTX 670 proudly into its throne seat pcie 3.0/2.0 x 16 ofc. When i had everything ready , i just clicked on the power button again. Three seconds later nothing happens. I stare blankly into the screen as my body starts shaking with anger. I start cursing out loud while at the same time unplugging everything again and plugging back in for a double check. NOTHING.

So here i am , totally clueless .All i know is that my card is telling me to **** off with my pcie 3.0/2.0 x 16 slots . I have absolutely no more ideas guys. All hope is on you ! Help me please ! S.O.S