Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: asrock z77 extreme9 stopped working

  1. #1

    Default 2nd asrock z77 extreme9 stopped working

    G'day all,
    I recently purchased an asrock z77 extreme9 with no hassles for a couple of months. Even had it o/c to 4.0 on air without any obvious problems (something my previous m/b couldn't). At the time I was running my dell u3011 with 2 gtx 670 4gb in sli and both dell u2711 on 2 gtx 570's. After some research I read that a single 570 could run both u2711's and figuring this would use less power removed one of the 570's and ran both u2711's from the one 570. It ran successfully for a few days and then stopped working all together. I replaced the (brand new) seasonic 1250w with a (brand new) enermax platimax 1500w but with no success. The pc would power up for a sec and then turn off. After more research I read that this was most likely the m/b. I just installed my new asrock z77 extreme9 m/b only to have the same result. If anyone can shed some light on where I should venture next please let me know as I would greatly appreciate any assistance.

    update: spent last 2 hrs trying different vid card/mem combinations but still no success. come on guys any suggestions are welcome

    My current specs:
    asrock z77 extreme9
    i7 2600k w/ noctua nf-p14 cooler
    16gb ram 4x4 corsair 1600mhz 9-9-9-24
    2 gtx 670 4gb
    2 gtx 570 1.5gb
    western digital 600gb velociraptor
    western digital 150gb velociraptor
    merc stealth
    razer mamba 4g
    Last edited by EricDraven12772; 12-13-2012 at 06:57 PM.

  2. #2
    Join Date
    Nov 2012

    Default Re: asrock z77 extreme9 stopped working

    Well, I'd start with the obvious question here. Are the CPU cooler fan(s) spinning?

    If yes, then I'd say it's time to remove the mb from the case and bench it with just the bare minimum.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Third stone from the sun

    Default Re: asrock z77 extreme9 stopped working

    I would also suggest trying to start the PC with the onboard graphics, which should at least start without its driver installed.

    Next, you cannot just use any memory in your new board, you must check if it is listed in the compatible memory list. The model number must be found, not just Corsair. If not I would go to two or one DIMM only, just so it can start completely. Also, nothing on the boards debug display?

    Back to your potential cause, running two monitors on one card, but that seems unlikely. If you can't start with the onboard graphics, I wonder if your CPU went south (or north, assuming where you live ), Very rare, but possible.

  4. #4

    Default Re: asrock z77 extreme9 stopped working

    as the pc only powers up for a second before it turns off again the cpu fans don't stand a chance of starting. i've tried again with the mb outside the case with only the psu hooked up, i.e no graphic card, ram, hdds, etc. but still no luck.

    as far as the ram is concerned i had my pc running without any hassles with the corsair ram for a few months before i decided to remove one of the 570's.
    i had a noctua nf-p14 cpu cooler which seemed to run okay even with the cpu o/c to 4.0.
    dr. debug remains blank.
    as i mentioned to wardog, i've tried starting with only the mb hooked up to the psu with no success.
    perhaps the cpu is kaput. as you said rare, but possible.

  5. #5
    profJim's Avatar
    profJim is offline Chief Munchkin + moderator
    Join Date
    Dec 2008
    Tacoma, WA. [USA]

    Default Re: asrock z77 extreme9 stopped working

    Is the 8-pin EPS12v power supply cable firmly connected to the motherboard socket?
    Your motherboard probably won't post unless you have at least one memory module connected in the proper slot.
    Do you have a case speaker connected to the motherboard?

    This is basic stuff, but many forget some of the basics.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts