Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock B75M-GL freeze after updating bios (not permanent brick)




  1. #1
    Join Date
    Dec 2012
    Location
    Romania
    Posts
    7

    Unhappy ASRock B75M-GL freeze after updating bios (not permanent brick)

    Hello, I've also sent a message on the official site, but i'm not sure they have an actual fix or if anyone will read. I'm hoping here to find at least one person with this model of mb and tell me the bios upgrade to the new version was successful. I have reasons to believe they've released a bad file. I'll explain here what's wrong...

    The 1.20 bios (first official update) for B75M-GL is freezing everything at the load screen after trying to update.
    Error message at the bottom right screen is "B4" and the brick message is just displaying the basic Asrock 1.0 bios version and date of manufacture above.
    Problem comes right after UEFI detects the bios version from my fat32 hdd and i push enter button to continue flash. Immediately, the system turns off, comes back after 3 seconds, and freezes with the B4 message.
    At first, i thought my mb was bricked because the failing bios update, but this is fixed by clearing CMOS - removing battery. And then, when i go to bios, it still displays as 1.00 version------ this is because update never happened.
    I redownloaded the file and repeated the process several times. It's the same freeze constantly if i don't do the battery reset trick.

    I did download v1.00(default) from the site, and just to prove myself i'm capable of flashing a stupid bios, it worked. I rewrote the v1.0 with 1.0 :) So the problem is from their end. I've also tried again after this to flash v1.20 and it freezes again. Also I've tried removing gpu/hdds/everything usb, you name it. Same thing!

    Maybe this is common and you guys here experienced this in the past with other mb's and bios versions? Or maybe i'm doing something wrong, even if i've tried everything possible to make it work. At least it's not bricked

    =============================
    =========================
    ===================
    EDIT:
    =============

    wow, i can't believe this. not only they've actually read my message, but they've fixed and uploaded a new bios version
    this is the support i've never had from other sh'it brands that used to ignore my messages or gave me retarded bot replies
    thank you ASRock!!!

    =========
    closed
    Last edited by tzily; 12-19-2012 at 07:31 AM. Reason: fixed

  2. #2
    MSXManiac's Avatar
    MSXManiac is offline Junior Member
    Join Date
    May 2013
    Location
    Porto Alegre
    Posts
    3

    Unhappy Re: ASRock B75M-GL freeze after updating bios (not permanent brick)

    I have a problem like your.
    I bought a B75M-GL last week and also bought an i5 2400 and 2 modules of 8 Gb DDR3 1333MHz memory.
    This motherboard replaces my previous set who is now with my wife.
    An ASUS P5QPL-AM with 4Gb DDR2 800MHz and Q8400.
    After mounting the enclosure, booted the system.
    The Linux brings up a good because most drivers already present in the kernel.
    There were no proprietary drivers available and apparently it makes little difference.
    Windows 7 was quite different.
    I had to do a fresh install.I installed the driver for the network card after installation and go to for Windows Update.
    After all updates installed and Java installed, I went to install the remaining drivers.
    The only problem is the VGA driver.
    I tested that is present on the CD drivers that came with the motherboard, the version on the AsRock site and the driver provided by Intel. The result is always the same.
    The system initializes, becomes the first Windows screen, and when it darkens the screen preceding welcome screen simply system freezes, keyboard, mouse, etc ...
    But if I leave with the generic VGA driver provided by Microsoft everything works normally.Before I forget, I updated the BIOS to the latest version, to 1.30 unless my memory fails me.
    What to do?

  3. #3
    MSXManiac's Avatar
    MSXManiac is offline Junior Member
    Join Date
    May 2013
    Location
    Porto Alegre
    Posts
    3

    Default Re: ASRock B75M-GL freeze after updating bios (not permanent brick)

    Well, I managed to solve this problem without the help of anyone.
    What I could find is that the original BIOS (v1.00) has this bug.
    The latest version of this BIOS (v1.30) have too!
    So I decided to test v1.20.
    Then began another headache because the files came corrupted of the four AsRock servers.
    Then I had delving the internet even find these files elsewhere.
    Found, installed the v1.20 BIOS and voila!
    It worked!
    Now we need to AsRock work some more and settle this once and for all!
    This includes a revision in Intel video driver that does not work with the hacked Windows kernel to work with 4 GB of memory or more.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •