Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: ASRock Z77 Pro3 & Radeon 7870 -> no pic




  1. #1
    Join Date
    Jan 2013
    Location
    United States
    Posts
    2

    Default ASRock Z77 Pro3 & Radeon 7870 -> no pic

    Hello people

    I posted this question to Tom's Hardware forum until I noticed ASRock have their own support forum. I got some tips but none of them worked.

    My Club 3D Radeon 7870 isn't working (no pic to monitor). By integrated graphics it works fine.

    I've updated Z77 Pro3's newest firmware and checked that PCI-E is working as primary buss. I changed also PCI-E Gen setting to value 1.

    I've tried also with another PCI-E buss but it's still same problem. I've checked both additional power cables but it's not working.
    Fan is spinning properly though.

    Graphic card should work because my old PC was Asus P5QL Pro and C2D E6400 and it worked fine.

    My specs:

    Intel i5-3570k
    ASRock Z77 Pro3
    Club 3D AMD Radeon 7870 2048 MB
    8192 MB DDR3 1600 MHz
    Nexus NX-5000

    Steps I've done after tips:

    - Tried with new Corsair 600W PSU
    - Cleared CMOS and took off Bios battery
    - Changed memory slot
    - Tried another PCI-E slot
    - Taken motherboard out from chassis and built whole PC with CPU, GPU, DDR and SSD on table

    It's still not working. My monitor's power led is only flashing and then it goes to power saving mode.

    Any suggestions?
    Last edited by parre; 01-08-2013 at 03:35 AM.

  2. #2
    Kornivsky is offline Junior Member
    Join Date
    Dec 2012
    Location
    Latvia
    Posts
    60

    Default Re: ASRock Z77 Pro3 & Radeon 7870 -> no pic

    Try to swap RAM slots.

  3. #3
    Join Date
    Jan 2013
    Location
    United States
    Posts
    2

    Default Re: ASRock Z77 Pro3 & Radeon 7870 -> no pic

    Quote Originally Posted by Kornivsky View Post
    Try to swap RAM slots.
    Tried already.

  4. #4
    Zoky is offline Junior Member
    Join Date
    Nov 2012
    Location
    Croatia
    Posts
    5

    Default Re: ASRock Z77 Pro3 & Radeon 7870 -> no pic

    http://forums.tweaktown.com/asrock/4...light=z77+pro3

    here you have a topic about same problem hope it helps, i had same issue with same components and 1,80 update fixed it.

    here you can find latest BIOS updates:
    http://www.asrock.com/support/download.asp?cat=BIOS

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •