Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 17 of 17

Thread: ASRock Game Blaster




  1. #11
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Game Blaster

    This from your diagnostics of the device is a clue:

    The driver for PCI Simple Communications Controller is not installed. Install the latest driver for the device.


    That tells me that you probably don't have the Intel Management Engine (IME) sofware installed. For your board and Windows 8 64 bit, that is Intel Management Engine driver ver:8.1.10.1286, from you board's download page.

    Not having it installed causes the error message you have.

    The BIOS update is also a good idea, even if the IME software is currently installed.

  2. #12
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Default Re: ASRock Game Blaster

    :P for the bios I thought the same way and went ahead and flashed to latest beta version (I plan to be overclocking) and I followed your advice and installed the IME driver that I found on the Driver cd and this did give a different behavior, THX studio program now detects audio but the outputs I want have still not been added to the playback devices list, I still only have two: speakers and digital output I need those two twice, one for the mb and one for the sound card both my mb and my sound card have 7.1 jack outputs and optical output so once the sound card detected I should have four. Changing the graphics of slot was of no importance it's just that the bottom slot can only go to 8x. I'm going to try reinstalling both the sound driver and the THX program.

  3. #13
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Default Re: ASRock Game Blaster

    Nope, I'm glad the THX software is working now though. Maybe if I follow these steps again with a new OS intall I might get more lucky. What I don't get is why the win 8 audio driver install doesn't run and the win 7 one does. (even though it only installs for the mb. should I consider installing the driver while the sound card is not plugged in?

  4. #14
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Default Re: ASRock Game Blaster

    i've also tried installing with onboard audio disabled nothing gives out of the three drivers i have Audio(v6.0.100.3004_WHQL) Audio(v6699) Audio(Refresh3_RC1) only the 6699 (which is the realtek onboard driver that works. within these folders i can see the creative sound blaster recon 3D which i can tell is the configuration panel for the game blaster i'd use if the driver were to install. Asrock really needs to put out new drivers for this because my take is they don't run
    Last edited by tatsu; 05-09-2013 at 06:22 AM.

  5. #15
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Default Summary

    First look at my system specs
    These are the parts I ordered to assemble my new computer. (the hard drives the case the cooling the graphics and the psu I used in my last PC)
    the 150Gb hard drive contained my old windows 8 installation. Windows 8 has the possibility to boot with changing hardware.

    For my first boot on this new machine I used this 150GB hard drive, it was useful for my indigo extreme installation, after this was done I got to know my new surroundings, checking system stability and most of all seeing if my Asrock Game blaster worked.
    And I found that the driver I got from Asrock failed to install with this error message: “Setup is unable to detect a supported product on your system.”

    This error message seems like one the one that would appear if the card was not plugged into the board but it is and I am using it for internet, it’s lan driver installed and detected it properly.

    There are three sound drivers to be installed:

    • realtek Audio(v6699)
    • Sound Blaster recon 3Di Audio(v6.0.100.3004_WHQL)
    • Sound Blaster recon 3Di Audio(Refresh3_RC1)

    The realtek driver works without problem it is for the onboard sound
    The other two affect the Game Blaster however they will not detect the card.

    I’ve been able to reproduce the problem on my old windows 8 hard drive and on three fresh installs of windows 8 on my revodrive.


    Since then I’ve been advised the install the intel IME driver which made a slight difference: I was able to get the THX software to accept realtek output whereas before it detected none.

    I’ve been told it was because I must choose between onboard and off-board sound in the bios and I must deactivate onboard sound, so after uninstalling all drivers I tried with onboard sound deactivated. And still I got the same result. I've also tried moving up and down the pci-e cards that I have from different slots. all the slots are set to gen 2 and the last slot containing my revodrive is on x8 (out of either x8 or x4)

    I have not tried on windows 7 yet but my ideal would be to have it on windows 8 as that is the only one of the two I own. I'm willing to use my second pc and my webcam to videoconference to be run through any manipulation needed on the hardware and bios as for the OS I'm willing to use teamviewer. thanks for any and all help you can share.
    Last edited by tatsu; 05-10-2013 at 08:11 PM.

  6. #16
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Default Fix

    I received the solution to my problem from Emily for Asrock tech support, she told me the Game blaster had to be in the third (and last) PCI-E 16x(which only runs at 8x max) slot and not the short PCI-E slot I had put it in which would only permit partial functionality. I had not thought the game blaster could even go into a PCI-E 16x slot. Upon this change, the drivers immediately worked. I cannot thank Emily enough, she knew the answer straight off the bat.

  7. #17
    tatsu is offline Junior Member
    Join Date
    Apr 2013
    Location
    france
    Posts
    10

    Angry Re: ASRock Game Blaster

    I've got the driver working however something's bugging me, I can't work out how to use the spdif-out in the SB control pannel, it only has the speakers as a selectable device and if i deactivate them in windows playback devices the SB control pannel turns off and has no selectable feature. Surely this wasn't a driver designed with only jack in mind. Can't the settings that can be applied to the jacks also be used on the digital output?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •