Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 6 of 6

Thread: z77 Extreme 6 - No VGA video output




  1. #1
    ethaniel86 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Singapore
    Posts
    3

    Question z77 Extreme 6 - No VGA video output

    My setup :
    i7-3770k
    Gigabytes nVidia 670
    Asrock Z77 Extreme 6

    When i plug in LCD monitor to D-sub VGA connector PC boot up but no video signal detected.. Should i connect to the discrete card instead?

    As far i know both should be working..hmm

    Pls help~

  2. #2
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: z77 Extreme 6 - No VGA video output

    Could you give the full specs and bios version plz, thx.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

  3. #3
    ethaniel86 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Singapore
    Posts
    3

    Default Re: z77 Extreme 6 - No VGA video output

    Im not sure bout the BIOS since i just got it from someone. No issue with the discrete card + DVI through..just curious why onboard VGA no video output..

    ps; profile updated with PC specs

  4. #4
    kick's Avatar
    kick is offline Senior Member
    Join Date
    Feb 2009
    Location
    Europe,the wild wild west.
    Posts
    1,223

    Default Re: z77 Extreme 6 - No VGA video output

    My board has no vga output or capability to use on chip gx ..but I did have trouble getting a gx card output.It eventually gave an output ,after numerous reseating of gx and only turning on the monitor as the machine was posting,but a77 owner..or other than a p67 owner at least! might have more info.
    Current Systems:

    Asrock p67 Extreme6.............. Gigabyte EP-45 UD3 ...................... Gigabyte 73 PVM S2
    Intel i5 2500k 4.8ghz................ Intel Q8400 3.8ghz......................... Intel D820 2.8ghz
    Zalman 10x cooler.................... Coolermaster V8............................ HP cooler
    8GB Gskill ripjaw ddr3.............. 4GB Gskill PI ddr2.......................... 4GB samsung ddr2
    60GB ssd/500GB HDD .............. WD 1TB hdd.................................... Seagate 160GB hdd
    GTX 460 1GB x2 SLI ................. Msi 9600GT 512MB(died) ........... Onboard gx
    Win7 64 ,750w psu(ocz)............ Win7 64 ,520w psu,seasonic...... Win XP pro ,400w psu

    HEC 6A34 case . ....................... Jeantec R2 case............................ Packard Bell case

    hoping to upgrade to http://www.thinkgeek.com/stuff/41/habicase.shtml
    http://www.flixya.com/video/140325/Animal-launching

  5. #5
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: z77 Extreme 6 - No VGA video output

    Quote Originally Posted by ethaniel86 View Post
    Im not sure bout the BIOS since i just got it from someone. No issue with the discrete card + DVI through..just curious why onboard VGA no video output..

    ps; profile updated with PC specs
    Download CPUZ, if you want to know what the BIOS version is, under motherboard, it should be on the first page of the BIOS also.


    If you have a video card installed the GTX 670, then you need to plug into the card not the onboard video, you also need to have the onboard disabled in the BIOS, if it has a option.

    If the OS had onboard drivers installed, they must be uninstalled, when you plug into the card you will see the screen, generic drivers kick in until you install the nvidia drivers.


    It might be a gigabyte card, but it is a nvidia chipset, get the drivers from nvidia. newest WHQL - 310.90
    Last edited by odiebugs; 02-14-2013 at 06:49 AM.

  6. #6
    ethaniel86 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Singapore
    Posts
    3

    Default Re: z77 Extreme 6 - No VGA video output

    alright got it working...have to remove gigabyte 670 and on board graphic works fine. getting new LED monitor next week..

    anyway my BIOS is 1.6 should i update to latest 2.x ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •