CPU- 2500k
MOBO- Z77 Extreme 4
Ram- Corsair Vengeance 8gb (2 x 4)
PSU - Corsair Gold 850w
HDD- 2tb WD Black
Win7 64 bit Ultra

I bought a Z77 Extreme4 for a new build with the parts above. Everything works fine until I put in 2 GPUs. When I do, after the Asrock logo screen hits and disappears, the system reboots. This build is for a friend and I have multiple systems around. I have switched out every single piece of hardware for other parts. I tried a 2600k, different PSU, different ram, different video cards, flashed to the newest Bios..Everything. So naturally I assumed the mobo was bad and I RMA'd through newegg. I got the new one and it does the exact same thing.

I tried it with 2 680s. A 670 and 680, with the bridge, without the bridge. Anytime two cards are put in..REBOOTS.

I have never used an asrock before. So I assume there is something I am missing. I have already bought a MSI board for that build, and everything worked fine. Since I can't return this Asrock, I would like to know what is wrong so I can use it and recoup the cost.

Any help is appreciated --Thanks