Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.




  1. #1
    MRK17 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Italy
    Posts
    13

    Default Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Windows 7 x64, Asrock Z77 Extreme 4, every driver installed and updated, latest bios installed on the mobo.

    Sometimes, when I hibernate my system, my system hangs on a black screen after the "resuming windows" screen. No HDD activity led, no signal on monitor, nothing works, not even the reset button, and I have to keep the power button pressed for 5 seconds and try again. Sometimes it works on the second try, but not always. There is nothing in Windows Even Log. Windows was recently reinstalled too.

    Why is this happening, how do I troubleshoot it, and how can I fix it?

    Other hardware: Gigabyte GTX560Ti, i5 3570K, 8Gb Corsair DDR3 1600Mhz, WD Blue hard disk as system drive.
    Last edited by MRK17; 02-28-2013 at 08:28 PM.

  2. #2
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Have you installed the latest driver(s) for you 560ti, those being 314.07 WHQL - Windows7 x64
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    MRK17 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Italy
    Posts
    13

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Yes I have.

  4. #4
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Seeings how you only listed the MB in your System Specs, now would be a good time to complete it by listing the other parts that make up your system.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    What do you have the BIOS setting for Deep Sleep (in South Bridge Configuration) set to?

    If you are truly using Hibernate, and not Sleep, the Deep Sleep setting should be set to S4.

    In the BIOS, in ACPI Configuration, be sure Suspend to RAM is set to Auto, and Check Ready Bit is enabled.

  6. #6
    MRK17 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Italy
    Posts
    13

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Quote Originally Posted by parsec View Post
    What do you have the BIOS setting for Deep Sleep (in South Bridge Configuration) set to?

    If you are truly using Hibernate, and not Sleep, the Deep Sleep setting should be set to S4.

    In the BIOS, in ACPI Configuration, be sure Suspend to RAM is set to Auto, and Check Ready Bit is enabled.

    I am using hibernation because I turn off the power to my system during the night. If I was using sleep, the system would not resume after completely losing power.

    That being said, all those options were already on your recommended settings.

    Is there any way to troubleshoot this problem without changing random settings in the bios and hoping for the best?

  7. #7
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Try this, as it's usually the display drivers or the NIC drivers. And this is assuming you use the onboard NIC.

    Either in the BIOS(preferred means) or in Device Manager disable the NIC and see if it will come out of hibernate reliably a few times.

    The latest Win7x64 Broadcom BCM57781 NIC drivers are 15.4.0.9 and can be downloaded HERE.
    Last edited by - wardog -; 03-01-2013 at 11:00 PM.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  8. #8
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    My Z77 Ex 4 board wakes from Sleep fine consistently.

    Another option for you would be the Intel Rapid Start feature, which is really their version of hibernate. It requires some configuration and a specific sequence of installing the components, which you can read about in this guide:

    http://www.asrock.com/support/note/IntelRapidStart.pdf

  9. #9
    MRK17 is offline Junior Member
    Join Date
    Feb 2013
    Location
    Italy
    Posts
    13

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    Thank you for your help.

    I installed the latest broadcom driver (the one on AsRock website wasn't the latest after all), I wonder if this will fix the problem. Like I said, it happens very randomly and it could go fine for a few days and then hang 10 times in a row. So far it seems to resume correctly.

    Regarding RapidStart, I tried it some time ago, and if I unplug the computer, the next time I power it on it complains about memory mapping being lost or something like that and resume from hibernation fails.

  10. #10
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Hibernation works randomly, sometimes I get a black screen when resuming, have to hard reset and try again.

    That's why I included the link back to the BCM57781 driver page at Broadcom. ASRock doesn't update the driver releases as far as I can tell unless there is a critical issue that a newer one will resolve and only then they seemingly only perform this for a short time after the/a board is released. My conjecture on the matter anyways.

    Let us know how things are going there after a while if you remember to.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •