Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: AsRock Z75 Pro 3, 5 beeps help




  1. #1
    Atrus27 is offline Junior Member
    Join Date
    Mar 2013
    Location
    PA
    Posts
    2

    Default AsRock Z75 Pro 3, 5 beeps help

    Hi, I just recently built a new computer. I have an AsRock Z75 Pro 3 Mobo, with an i5-3350P LGA1155 Processor, adn Corsair Vengence Ram (CMZ8GX3M2A1600C9B). When I turn the computer on it beeps 5 times and does not post. I have reseated everything in the computer with no luck. If I remove the RAM i get much slower beeps that will pause and then repeat. I believe its only 2 beeps then the pause. I went to the AsRock website and looked up my Mobo, and what RAM it was able to use. I was not able to find my RAM listed. I am not sure how often the list is updated but i was wondering if this could be my issue. I have no other RAM that I can quickly slap in to find out if that is the issue. This is a budget build so I can't even really just go out and buy one off the shelf. I just want to hopefully get some feed back before I send the RAM back and get another version in hopes that is the issue. I have not installed any video card or anything besides the HDD, which is a 1tb drive. Any help would be GREAT. Thank you.

  2. #2
    Rale is offline Junior Member
    Join Date
    Dec 2012
    Location
    UA
    Posts
    83

    Default Re: AsRock Z75 Pro 3, 5 beeps help

    i5-3350P no iGPU. You build is require discrete video card to run.
    Last edited by Rale; 03-19-2013 at 03:49 PM.

  3. #3
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: AsRock Z75 Pro 3, 5 beeps help

    Hi Rale,

    You're right!
    Thanks!

    Dear Atrus27,

    Your CPU i5-3350P doesn't support onboard graphics, please kindly refer to below link to check the spec. of CPU i5-3350P.
    Intel Official website Link: ARK | Intel® Core

    Please install an add-on VGA card to try again.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

  4. #4
    Atrus27 is offline Junior Member
    Join Date
    Mar 2013
    Location
    PA
    Posts
    2

    Default Re: AsRock Z75 Pro 3, 5 beeps help

    That worked Perfectly. Thank you both. Was a late night and didn't even think to just throw my card in, silly me thinking the on-board would work. You saved me a return on RAM which had nothing to do with it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •