Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asrock Z77 Pro3 wont save manual ram timings

  1. #1
    Join Date
    Mar 2013
    United States

    Default Asrock Z77 Pro3 wont save manual ram timings

    I am having problems trying to lower or raise my rams latency timings in anyway in the Pro3's UEFI. The XMP Profile has two settings I can choose from XMP Profile 1.2 or Auto (I have tried both). I currently have installed
    G.Skill DDR3 Ripjaws 1600Mhz 9-9-9-24 1.5V. Is there a setting I am supposed to turn off or on, or something I am missing? Also my Bios is fully up to date.

    Here Are the basic system specs just for FYI

    I5-3470 Overclocked to 3.8GHZ
    ASRock Pro3 Z77 Motherboard
    16GB G.Skill DDR3 1600Mhz
    Radeon 7870

    Thanks in advance for any help

  2. #2
    KrisW is offline Junior Member
    Join Date
    Mar 2013

    Default Re: Asrock Z77 Pro3 wont save manual ram timings

    Have you tried to clear cmos? My Extreme4 did much the same recently and clearing cmos rectified the problem.Do make sure that you have a record of any hard to replicate settings first though,can be a pain to hit that sweet spot if you forget a vital stepping.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts