Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: z77 pro4-m bios update failed




  1. #1
    Join Date
    Mar 2013
    Location
    Slovenia
    Posts
    3

    Default z77 pro4-m bios update failed

    Hi.
    I own z77 pro4-m motherboard. i have downloaded the newest bios (1.90) from official asrock website. i used windows method of updating, so i've extracted the files, ran the exe, confirmed the bios update warning and bam - my computer restarted immediately and it's now beeping. i have 3 beeps, short pause, and 3 beeps again. also, my screen is black.

    tried removing battery and it didn't help.


    any help is greatly appreciated.

  2. #2
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: z77 pro4-m bios update failed

    Hi diablosi,

    Did you see the procedure of updating BIOS under OS?

    Or system reboot before updating BIOS.

    Please kindly tell me the detailed symptom, I'll check it.
    Thanks!

    Have a nice day
    ASRock TSD
    Emily

  3. #3
    Join Date
    Mar 2013
    Location
    Slovenia
    Posts
    3

    Default Re: z77 pro4-m bios update failed

    Hi,

    thanks for the reply. I'll try to describe my procedure as detailed as possible.

    1) Downloaded 1.90 Bios for Asrock Z77 Pro4-M from offical Asrock website (ftp://europe.asrock.com/bios/1155/Z7...(1.90)WIN.zip)
    2) Extracted the .zip file (although it contains only 3 files, the image on "How to install" shows more)
    3) Restarted the system
    4) Upon logon, I've closed all the programs running in the background (Steam, Origin etc..)
    5) Run the .exe file from the extracted zip.
    6) The console window showed for a second or two
    7) System restarted and it started to beep. 3 short beeps, approximately 1 second pause and 3 short beeps again. No more beeping after that.
    8) There is no video, so I can't actually do anything - also tried connecting to onboard graphics -> same problem, no video output.

    I have no idea how to restore or flash the bios again to it's original version and settings.

    Regards

  4. #4
    Join Date
    Mar 2013
    Location
    Slovenia
    Posts
    3

    Default Re: z77 pro4-m bios update failed

    It has been over a week and still no reply from ASRock support. Good job! /sarcasm off

    This has officially made it to my "Top10 not to buy list" -> Never buy ASRock

    Anyway, I've taken my PC back for repair and they were kind enough to replace my motherboard. However (look at the top10 list above), I have chip in a few euros and got myself another board.

    Regards

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •