Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: cant find bios v1.6 or Z77 Extreme4-M on website..but it come with 1.6 instlled 2013




  1. #1
    Join Date
    Oct 2008
    Posts
    35

    Default cant find bios v1.6 or Z77 Extreme4-M on website..but it come with 1.6 instlled 2013

    cant find bios v1.6 for Z77 Extreme4-M on website..but it come with 1.6 on t (sticker too) bios dated 13/1/03

    1 are asrock not updating their website?...maybe i should not but asrock any more if they going to drop support for their boards..

    it been 5 months already..latest board coming with 1.6 website has1.5 (2012) and are their newer version than 1.6?

    how about latest drivers

  2. #2
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: cant find bios v1.6 or Z77 Extreme4-M on website..but it come with 1.6 instlled 2013

    If the motherboard came with 1.6, and the newest on the website is 1.50, why do you care, if you have 1.6 why would you flash 1.6 when you have it. You make no sense.

    No motherboard site has the newest or beta drivers out, Asus, Gigabyte, MSI,. they all stick with drivers that are the most stable. Some have beta under Beta.

    If you want the newest drivers, you find the hardware, and you look for the newest drivers.


    The newest chipset out is 9.4.0.1017, the top Asus board shows V9.3.0.1021 for chipset. Same as Gigabyte. ***ASROCK has the 9.3.0.1025 newer then Asus and Gigabyte.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: cant find bios v1.6 or Z77 Extreme4-M on website..but it come with 1.6 instlled 2013

    Quote Originally Posted by terrabyteone View Post
    cant find bios v1.6 for Z77 Extreme4-M on website..but it come with 1.6 on t (sticker too) bios dated 13/1/03

    1 are asrock not updating their website?...maybe i should not but asrock any more if they going to drop support for their boards..

    it been 5 months already..latest board coming with 1.6 website has1.5 (2012) and are their newer version than 1.6?

    how about latest drivers
    That's weird, I wonder if 1.60 was released and then removed (unlikely), or ASR simply did not post 1.60 in the download page.

    New BIOS updates can be to fix issues, and your board just doesn't have any problems. The only thing that might be called missing for your board compared to mine, Z77 EX 4, is the Intel UEFI RAID configuration in BIOS setup. My board's last BIOS update was on 1/29/2013, so about a month after your board's last update, 12/25/2012. Looks like you have the latest BIOS now.

    With Haswell CPUs and boards coming soon, that is where the focus is now.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •