Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Device Drivers Unknown




  1. #1
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Device Drivers Unknown

    Hi,

    I have the AsRock Z87E-ITX motherboard and have installed Windows 8 64bit.

    These are things listed in the Device Manager, I have no idea what they are, hoping someone here does?

    http://i.imgur.com/NE3U1zS.jpg

    I am not used to Windows not finding drivers :(

  2. #2
    Join Date
    Jun 2013
    Location
    Zagreb
    Posts
    3

    Default Re: Device Drivers Unknown

    Hello :)

    Network controller is LAN on CD if you have it, for rest just use INF installer on CD and then see if it will help :)

    Cheers

  3. #3
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Re: Device Drivers Unknown

    I have LAN installed, network is probably Wifi but for the rest, my system does not have a dvd/CD drive which is why I am asking here so I know which drivers to download :)

  4. #4
    Join Date
    Jun 2013
    Location
    Zagreb
    Posts
    3

    Default Re: Device Drivers Unknown

    Have you been on their site? :)

    ASRock > Z87E-ITX

    Install all the drivers that are there :) I still have one "unknown" also, but i am gonna change mobo so i didn't install it. I think that unknown is ACPI or power management one located on their site.

    But to be certain install everything under drivers section and that's it :)

    Cheers

  5. #5
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Re: Device Drivers Unknown

    Well I didn't really want to do that, in case I don't want one item installed.

    I thought someone here would know each part, but I guess I am out of luck.

    Thanks :)

  6. #6
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Re: Device Drivers Unknown

    I have now downloaded all drivers, but these 2 are left.

    PCI Simple Communications Controller
    SM Bus Controller

    I got every single driver available.

  7. #7
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Device Drivers Unknown

    Quote Originally Posted by bmancreations View Post
    I have now downloaded all drivers, but these 2 are left.

    PCI Simple Communications Controller
    SM Bus Controller

    I got every single driver available.
    Did you install this one: Intel Management Engine driver ver:9.0.0.1287

    Your symptoms tell me you haven't.

    You sure don't need all the software/drivers, unless you plan on using every last feature your board has.

  8. #8
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Re: Device Drivers Unknown

    Yes I have downloaded it.

    I never ran the setup.exe but through the Device Manager, select the folder, and it finds nothing.

  9. #9
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Device Drivers Unknown

    You MUST run the the setup.exe, that is not a simple driver, it installs multiple things. Give that a try, you'll see...

  10. #10
    Join Date
    Jun 2013
    Location
    Canada
    Posts
    10

    Default Re: Device Drivers Unknown

    That did take care of the PCI, thanks :)

    SM Bus Controller is still not done. Which one is that, cause I didn't run the .exe on any of them. I always liked doing it through Device Manager.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •