Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: SATA Not Detected: ASRock z77 Professional-M




  1. #1
    Join Date
    Jun 2013
    Location
    Brazil
    Posts
    1

    Default SATA Not Detected: ASRock z77 Professional-M

    Hi,

    I've just mount a desktop for me with this specs:

    • Mobo: ASRock z77 Professional-M
    • Processor: i5-3570k
    • Graphic Card: HD7950
    • RAM: 8 GB
    • SSD: Samsung 840 120 GB (plugged on SATA3)
    • HDD: Seagate SATA3 1 TB
    • DVD reader/writer: LG (plugged on SATA2)
    • ...


    The problem is when I enter on UEFI Setup > System Browser or Advanced > Storage Configuration shows that no SATA (2 or 3) is detected! I've tryed all SATA ports, changed cables, plug 1 or 2 cables, reset CMOS, re-plug other components,...

    There's nothing installed on desktop cause I can't access SSD, HDD or CD reader with Windows Instalation.

    Any ideia? Can be a Mobo problem?

    Thx,
    Luiz

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: SATA Not Detected: ASRock z77 Professional-M

    Is SATA Controllers set to Enabled?

    Set SATA Aggressive Link Power Management to DISABLED.

    SATA mode should be set to AHCI, or RAID if you plan on using that.

    You must be certain your SSD and other drives are connected to the INTEL SATA 3 ports, NOT the ASMedia ports which will not work on until the OS and its driver is installed. Check the manual for the Intel port's location.

    Check the power connections to the drives, since at least a few of your drives should be seen by the System Browser, the ones on the Intel ports.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •