Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock z87 Extreme 4 Ethernet problems




  1. #1
    Join Date
    Jun 2013
    Location
    Lubbock
    Posts
    1

    Default ASRock z87 Extreme 4 Ethernet problems

    My motherboard fails to recognize my network adapter (ethernet cord).
    Is my motherboard faulty?
    I had tried 5-6 different ethernet cords, still the same result.
    My ethernet cord is plugged in my computer via the modem/router and my computer fails to recognize the network adapter. When I troubleshoot the problem, it gives me an option to either 'Fix' or 'Skip' the problem. When I press fix the problem on all, it states that 'no driver was found.' Can anyone please help me with this?

    System Specs : i5-4670k
    Cooler - h100i
    GPU - Sapphire Vapor X 7970
    PSU - Corsair TX650 80 plus bronze
    SSD - Samsung 840 pro
    OS - Windows 7
    Last edited by Rossporto; 06-30-2013 at 05:04 AM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock z87 Extreme 4 Ethernet problems

    You must install the LAN driver from your board's download page, Lan driver ver:18.2.63.0, the new chip it uses cannot use any built in network driver that Windows 7 or 8 has.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •