Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: USB 3.0 not working on Z87E-ITX Motherboard




  1. #11
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: USB 3.0 not working on Z87E-ITX Motherboard

    I have an ASR Z87 board, and have several USB 3.0 flash drives, and they all work fine, recognized, etc. I'm also using Windows 8 with the standard Window USB 3.0 driver installed automatically.

    This is a Patriot Supersonic Pulse 64GB USB 3.0 flash drive:

    USB 3.0 not working on Z87E-ITX Motherboard-ssd-patriot-64gb-usb-3-0-mbs-6-28-2013-png

    That test is not with XFast USB installed.

    Sorry but I must ask, do you have the Intel Management Engine driver ver:9.0.0.1287 software installed? All the chipset features will not be active without it.

    Intel does not list a USB 3.0 driver for their own Z87 boards when used with Windows 8. Actually, the Windows 8 USB 3.0 driver is sourced from Intel AFAIK, for use with Intel chipset boards.

    Intel does have a USB 3.0 driver for Z87 boards using Windows 7. I'll add the link to it here, but I DO NOT know if it will work correctly, or even install on your PC. Try it at your own risk:

    https://downloadcenter.intel.com/Det...T-75K&lang=eng

  2. #12
    Sekito is offline Junior Member
    Join Date
    Jul 2013
    Location
    United States
    Posts
    10

    Default Re: USB 3.0 not working on Z87E-ITX Motherboard

    I have the Intel Management Engine driver installed. The win7 drivers won't install.
    USB 3.0 still not working.

  3. #13
    Sekito is offline Junior Member
    Join Date
    Jul 2013
    Location
    United States
    Posts
    10

    Default Re: USB 3.0 not working on Z87E-ITX Motherboard

    Okay so I went ahead and tried to dual boot Windows 7 Professional 64-Bit. Everything was fine straight from the get go, all ports were working (under USB 2.0), checked USBDeview and my usb 3 drive was showing as 2.10. So I went ahead and installed INF and Intel Management Engine. Everything was still readable I believe. Then I installed the Intel USB 3.0 drivers for Windows 7 and I end up in the same situation I'm in for Windows 8.

  4. #14
    Sekito is offline Junior Member
    Join Date
    Jul 2013
    Location
    United States
    Posts
    10

    Default Re: USB 3.0 not working on Z87E-ITX Motherboard

    I plugged in an ADATA NH03 external HDD and it is showing up in Windows. USBDeview indicates a USB version of 3.00. Sadly I don't have any more USB 3.0 devices on hand to test.

    Perhaps it's just poor compatibility between my flash drive and the mobo? If so, is this something that a BIOS update or usb driver update can fix?

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •