Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: Problem with LAN port on ASRock B85M-ITX




  1. #1
    nwcyclist is offline Junior Member
    Join Date
    Jul 2013
    Location
    Washington
    Posts
    2

    Default Problem with LAN port on ASRock B85M-ITX

    Hello! I recently purchased the ASRock B85M-ITX motherboard, but when I installed I was disappointed to find out that the LAN port doesn't work. An orange light comes on when I plug in the ethernet chord, but I believe there's supposed to be a green light that comes on as well. I don't think it's an issue with the OS because I don't think the BIOS can access the internet either. When I tried Using the Easy Driver Installer feature It came up with no drivers. I don't want to return it until I know that I can't fix it myself.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Problem with LAN port on ASRock B85M-ITX

    No drivers found... perhaps due to using Windows XP? As listed in your PC specs?

    Your board's download page has no drivers for XP or Vista, mainly because many of the features on your CPU and B85 chipset have driver support only for Windows 7 and 8.

    At some point, XP will be left behind, and for Intel, that point in time is now.

    An XP driver for your Qualcomm Atheros AR8171 LAN chip can be found here: Download Qualcomm Atheros AR8171/8175 PCI-E Gigabit Ethernet Controller (NDIS 6.20) for all Windows Versions

    Have you been able to install any drivers on that board with XP? Just the INF files for example? You may never find XP compatible drivers for all the features your CPU and board provides. Check Device Manager for problem devices. Good luck.

    Linux drivers of course must be taken care of yourself.

  3. #3
    nwcyclist is offline Junior Member
    Join Date
    Jul 2013
    Location
    Washington
    Posts
    2

    Default Re: Problem with LAN port on ASRock B85M-ITX

    I was using Windows xp, and the drivers wouldn't support that I guess. I was able to find a broken laptop lying around with an intact hard drive with windows 7 on it, and that seemed to have solve the problem. I still wasn't able to use the easy driver install feature, and I had to install a dvd drive just so I could install the drivers.

  4. #4
    Join Date
    Mar 2011
    Location
    Taiwan
    Posts
    562

    Default Re: Problem with LAN port on ASRock B85M-ITX

    Dear nwcyclist,

    Intel 8 series M/B doesn't support Windows XP.
    Please kindly install Windows 7 or 8 as your operating system.

    The LAN works normally under Windows 7 and 8.

    Thanks!

    Have a nice day
    ASRock TSD
    Emily

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •