Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: ASRock Z77 Pro4 Updated BIOS to 1.80, now it works in AHCI mode instead of RAID?!?




  1. #1
    Join Date
    Jul 2013
    Location
    dc
    Posts
    1

    Default ASRock Z77 Pro4 Updated BIOS to 1.80, now it works in AHCI mode instead of RAID?!?

    So yesterday I updated my BIOS on the ASRock Z77 Pro 4. I had previously set the SATA controllers to RAID during Windows installation on a normal HDD. Later I added a SDD and got it working on Intel RST. After the BIOS update, it somehow reconfigured things and reset the controllers to AHCI. Windows now boots normally under AHCI mode (of course, Intel RST no longer works). When I try switching to RAID mode in BIOS, the Raid BIOS screen comes up, and if I try booting into windows the system freezes.

    Any ideas on how to fix this? Can I get RAID mode back without reinstalling Windows? How is it even possible that Windows now works in AHCI mode now?


    Thanks in advance to anyone who can help.

    (Specs are: Win 8, 8 GB DDR3 RAM, 1 TB Toshiba HDD, 60 GB OCZ Vertx 3 SSD, core i3-3220)

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z77 Pro4 Updated BIOS to 1.80, now it works in AHCI mode instead of RAID?!?

    BIOS updates will always reset most if not all BIOS settings to default values, and AHCI is a default value. Sorry to say, that is a standard thing that happens on any mother board. The first rule of BIOS updates is immediately on the first boot after a BIOS update, is get into the BIOS and reset any settings that are not default values that you normally use. Another bad side affect of BIOS updates is any BIOS setting profiles you have saved are usually removed and must be created again.

    Windows works in AHCI mode because the IRST driver you installed is both an AHCI and RAID driver. The problem you have now setting the SATA mode to RAID was caused by booting Windows in AHCI mode after the BIOS update. That caused a small but important change in the Windows registry that determines what driver is loaded, or in your case how the driver is loaded. Difficult to explain, but the bottom line is it happens.

    What you need to do now is Google on "changing to RAID mode from AHCI", and you'll find instructions for the registry edit needed to do this. This allows you to change to RAID without installing Windows again. People do this all the time, and it is a real fix that simply works given how Windows works.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •