Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: Z87 Extreme3 pgu problems




  1. #1
    Join Date
    Aug 2013
    Location
    sweden
    Posts
    3

    Default Z87 Extreme3 pgu problems

    Hello
    When I connect my gigabyte 7970 to the motherboard, the gpu just sends a black signal. It sends a signal as my moniter reacts to it, but its just completely black. The onboard hdmi works fine if i disconnect the gpu. I have 2 7970, and both has the same problem so one would guess the problem is with the motherboard. I have tried both pcie slots, no difference. The gpu is connected with both the required cables. Is my motherboard defect or what could be the problem?

  2. #2
    Tyler.Bernath's Avatar
    Tyler.Bernath is offline TweakTown Consumer Storage Editor
    Join Date
    Jan 2013
    Location
    Ohio
    Posts
    69

    Default Re: Z87 Extreme3 pgu problems

    Using latest bios? Version 2.10 if I remember correctly

  3. #3
    Join Date
    Aug 2013
    Location
    sweden
    Posts
    3

    Default Re: Z87 Extreme3 pgu problems

    Yes, flashed it to 2.10 and its still the same.

  4. #4
    Tyler.Bernath's Avatar
    Tyler.Bernath is offline TweakTown Consumer Storage Editor
    Join Date
    Jan 2013
    Location
    Ohio
    Posts
    69

    Default Re: Z87 Extreme3 pgu problems

    Go into bios and make sure PCI express graphics or peg is selected as first option for graphics at boot,insert gpu in top slot and connect power to gpu,connect monitor to gpu and turn on system

  5. #5
    Join Date
    Aug 2013
    Location
    sweden
    Posts
    3

    Default Re: Z87 Extreme3 pgu problems

    Its already set to pcie. So nothing changes.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •