Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: ASRock z87 e-itx DTS Connect / Interactive Problem in Win7 ultimate with WMC, WMP, etc




  1. #1
    Join Date
    Dec 2009
    Location
    North Pole
    Posts
    7

    Default ASRock z87 e-itx DTS Connect / Interactive Problem in Win7 ultimate with WMC, WMP, etc

    Hi all,

    I have the new z87 E-ITX motherboard. I am using it in a HTPC hooked up to a received via optical cable. I have bought this mobo specifically for having the DTS Interactive feature because, as I have found out a while ago, games do not send out encoded sound but rather straight 5.1 etc surround and so I was only getting stereo sound.

    Now.. I am using the latest drivers (also tried the ones from RealTek, same thing) and on the digital out I do have the DTS interactive feature in the Advanced section and DTS connect in the Enhancements section.

    The problem however is that if I select DTS interactive, Windows Media Player throws an error and Windows Media Centre as well (files required are not installed etc). Actually windows complains about ANY enhancement that is not turned off so I wonder how can these be used at all? VLC outputs no sound, nor do any games when using DTS surround :-( In WMC I do not have auto level for sound for TV or DVD. I read all kinds of posts and tried all kinds of settings in WMC to no avail...

    If I set digital output to stereo and no enhancements, all is good again HOWEVER I am back to square one (and why did i get DTS interactive then for?)!

    I have a plain Win7 ultimate installation with only AC3Filter installed. AC3 Filter is configured for passthrough SP/DIF and do not use AC3 encoder. I have used the Filtertweak tool only to specify MERIT for the Windows driver priority. I have installed no codec packs. (Uninstalling AC3 Filter did not make any difference btw.)

    Can anyone please explain how to use DTS connect and if it ever works, will I need to switch it on and off every time I play games vs using WMP and WMC? There must be a way to use it if it is provided with the mainboard, else what is the point (and extra$$) ?

    I hope it is something obvious (setting, software i may need etc) that I may have missed. Many Thanks!

    (PS Live TV witj Dolby Digital also comes out as PCM only, that may be a separate issue but I have this feeling there are some settings I have no idea about)

    EDIT it seems this enhancement problem is due to the Realtek drivers... Same problem on my z77 mainboard PC! No matter WHAT enhancement I select, Media player throws an error and Windows says the enhancement is causing problems. I am using Realtek 2.71 driver version. ??? Does everyone with ASRock boards have this issue I wonder?
    Last edited by advarp; 08-22-2013 at 09:36 AM.

  2. #2
    Shiari is offline Member
    Join Date
    Jun 2013
    Location
    Nottingham
    Posts
    143

    Default Re: ASRock z87 e-itx DTS Connect / Interactive Problem in Win7 ultimate with WMC, WMP, etc

    I don't have your board but on mine I have tried an optical cable along with HDMI to the receiver, and I couldn't get it to work at all (no sound whatever I tried ... it might be a realtek driver issue, or perhaps they're just not compatible?). Switched audio output to HDMI and all is well. I don't mind, since from what I've heard, HDMI also has higher bandwidth than coax and optical.

    Sorry I can't be of more help though.

  3. #3
    Join Date
    Dec 2009
    Location
    North Pole
    Posts
    7

    Default Re: ASRock z87 e-itx DTS Connect / Interactive Problem in Win7 ultimate with WMC, WMP, etc

    Ok thanks - the main issues here are 1) the fact that any RealTek enhancement (for ANY output, ie also speakers) seems to break WMP and WMC and hence 2) as the so-called DTS interactive and DTS connect are implemented as an enhancement ... they do not work.

    Live TV works Ok, Dolby etc goes through... my board only has one HDMI and I'm using it for the projector. The other connectors are Displayport and DVI - so I cannot use HDMI for audio out (and my received has no HDMI anyway)...

    I might end up using the analog outputs, but my receiver does not have these either so I might end up buying another and so on... it all cascades on from a small driver issue :-(

    EDIT This ASROck Z87 is CRAP - or rather the driver support. I just realised I can watch movies using my $300 ASUS Netobook with HDMI output and a HDMI and SPDIF splitter - HDMI to projector, SPDIF to my old surround system. With a USB tuner I can also watch TV and with a USB HDD I can have all the movies I want. I have built this HTPC for nothing. ASRock... YOU S*U*C*K.
    Last edited by advarp; 08-24-2013 at 04:27 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •