Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Asrock GNU/Linux Support




  1. #1
    Join Date
    Aug 2013
    Location
    ME
    Posts
    1

    Question Asrock GNU/Linux Support

    I would like Asrock to provide GNU/Linux support for their products. What is their policy on this? Why don't they do it?

    For example, on the Asrock Z87 Extreme6/ac page, there are no .deb or .rpm files and no mention of GNU/Linux at all. I think that it would not cost Asrock very much in time or money to have a couple of their engineers test their systems using a popular distribution, like Ubuntu, Fedora or Trisquel. If I ran Asrock, I would want to do this as a matter of pride in my products. The engineers could then have some files put on the web page and on the CD that comes with the board, since one can't reach any webpages in the first place, in order to download things.

    Asrock should do this with all their products.

    In the case of the Extreme6/ac:

    1) Ethernet Adapter

    The LAN ethernet adapter is not recognized by Debian Wheezy, for example. (I believe that the required Broadcom driver, tg3, which is released under GPL, can be found here.)

    With Ubuntu 13.04 Raring RIngtail, the ethernet is detected automatically during installation, and the machine can reach the internet throughout the process.

    2) VGA Drivers

    These are not detected with Wheezy. GNOME3 does not load and defaults to a GUI using Gnome Fallback, which does not require 3D capability. With Raring, video worked right away. This is fortunate, as Unity, the Ubuntu GUI, there is no 2D fallback, as far as I know. (This makes Ubuntu painfully slow if using it in a virtual machine without 3d capability.)

    Somebody has kindly checked the extreme4 for functionality here.

    4) Bluetooth

    Bluetooth did not work after installation of Wheezy. Drivers must be required.

    5) Dual Boot

    Windows 8 (sorry!) was already installed on another disk, from which the system was booting. After installing Wheezy alongside Windows, the system kept booting to Windows! It was difficult to get it to boot to GNU/LInux. Evenutally, I was able to solve this by:

    i) unplugging the Windows disk, so that it was not powered on during boot, after GNU/Linux was installed.
    ii) booting the system - it found the GNU/Linux installation
    iii) selecting to boot into GNU/Linux
    iv) after reaching the desktop, shut down
    v) plug in the Windows disk
    vi) set BIOS to boot from GNU/Linux disk
    vii) boot as usual, and select GNU/LInux or Windows

    This worked for Wheezy and Raring

    (The problem I had was that after installing GNU/Linux, this disk disappeared from the UEFI boot options.)

    I will update this post, if I find some useful information.
    Last edited by yeehi; 08-31-2013 at 10:30 PM. Reason: Added info and formatting.

  2. #2
    Join Date
    Nov 2013
    Location
    Tampa, FL
    Posts
    3

    Default Re: Asrock GNU/Linux Support

    Agree with you, this is bad on ASRock's part to not provide Linux drivers

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •