Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Z77 OC Formula Not showing XMP for Kingston HyperX Beast




  1. #1
    Join Date
    Aug 2013
    Location
    Chicago, IL
    Posts
    2

    Default Z77 OC Formula Not showing XMP for Kingston HyperX Beast

    Hello,

    I just installed my ASRock Z77 OC Formula Motherboard with the i7 3770k CPU and Kingston HyperX Beast 2x8GB Memory.

    My problem is that I cannot set my Memory past DDR @ 1600Mhz. It is rated for 2400 Mhz. There is no option to set the memory past 1600Mhz.
    There is not an option to select an XMP Profile!

    I checked on the ASRock website for compatible memory before I bought the Kingston Hyperx Beast 2x8GB.

    I did some research and found that if I update the motherboard bios it might show up.
    I updated from version 1.30 to 2.30 through the Motherboards Internet Flash, but the XMP is still not showing up.

    Does anyone have any idea why the XMP profiles are not showing up, and why I cannot set the memory to run at the rated 2400Mhz this memory was built for?

    Thanks in advance.

    -Dave

  2. #2
    Join Date
    Aug 2013
    Location
    Chicago, IL
    Posts
    2

    Default Re: Z77 OC Formula Not showing XMP for Kingston HyperX Beast

    I also noticed that the Nick Shih OC Profiles are not showing up now either after the Bios Update. What the heck.???

    And I can not raise the multiplier past x39?? I think my board is a paper weight.
    Last edited by leblanc980; 09-01-2013 at 11:21 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •