Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 4 of 4

Thread: ASRock MOBO P/N and S/N do not match the box




  1. #1
    Join Date
    Sep 2013
    Location
    USA
    Posts
    3

    Default ASRock MOBO P/N and S/N do not match the box

    I purchased an ASRock LGA1155/Intel Z75 Pro3 MOBO from Amazon, and the box arrived yesterday. The box was sealed with a rather large piece of packing tape, and I found the MOBO inside does not match the P/N on the box. Further, the label on the MOBO is slightly smudged.

    I Googled the P/N's, and the one on the box corresponds to what I ordered, but the one on the MOBO does not bring up any results, so that worries me. I am thinking I should return it, but thought I would ask here, since the ASRock website had a link to this forum.

    P/N on the box: 90-MXGM10-A0UAYZ
    P/N on the MOBO: 80-MXGM10-A1A22

    Thanks.

    Mark

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock MOBO P/N and S/N do not match the box

    Quote Originally Posted by giomania View Post
    I purchased an ASRock LGA1155/Intel Z75 Pro3 MOBO from Amazon, and the box arrived yesterday. The box was sealed with a rather large piece of packing tape, and I found the MOBO inside does not match the P/N on the box. Further, the label on the MOBO is slightly smudged.

    I Googled the P/N's, and the one on the box corresponds to what I ordered, but the one on the MOBO does not bring up any results, so that worries me. I am thinking I should return it, but thought I would ask here, since the ASRock website had a link to this forum.

    P/N on the box: 90-MXGM10-A0UAYZ
    P/N on the MOBO: 80-MXGM10-A1A22

    Thanks.

    Mark
    I don't own your board, so I can't verify the part number.

    The box and board should have a Serial Number that matches, which you should check. DO NOT post the Serial Number in this forum.

    You mention SN in the title of your thread, but not in the post itself so I'm confused about the SN, does that not match too?

    Your board should have included two SATA data cables in a sealed bag, and the metal I/O panel that mounts in your PC case should have been in sealed plastic.

    Hopefully ASRock can verify the part number for you, and the SN for you, in a private message when they (Emily?) replies to your thread.

    This is an example of why Amazon worries me, sometimes you have no idea what the source of the item will be. Also it is easy to not see the "used" category for some products.

  3. #3
    Join Date
    Sep 2013
    Location
    USA
    Posts
    3

    Default Re: ASRock MOBO P/N and S/N do not match the box

    Quote Originally Posted by parsec View Post
    I don't own your board, so I can't verify the part number.

    The box and board should have a Serial Number that matches, which you should check. DO NOT post the Serial Number in this forum.

    You mention SN in the title of your thread, but not in the post itself so I'm confused about the SN, does that not match too?

    Your board should have included two SATA data cables in a sealed bag, and the metal I/O panel that mounts in your PC case should have been in sealed plastic.

    Hopefully ASRock can verify the part number for you, and the SN for you, in a private message when they (Emily?) replies to your thread.

    This is an example of why Amazon worries me, sometimes you have no idea what the source of the item will be. Also it is easy to not see the "used" category for some products.
    Thanks for the reply, parsec. The serial numbers on the box and board DO NOT match. I do have the SATA cables and I/O board in sealed plastic; the board anti-static bag was not sealed, but I don't know if they normally are for MOBO's. When I have purchased HDD's, those anti-static bags have a seal on them. I will be curious to see what ASRock says about this, but I don't want this to be a long process. If they want me to return it to them, requesting a replacement through Amazon is probably going to be much quicker, as I have Prime, and Amazon will send a replacement before I return the board to them.

    Mark

  4. #4
    Join Date
    Sep 2013
    Location
    USA
    Posts
    3

    Default Re: ASRock MOBO P/N and S/N do not match the box

    I decided to just return it to Amazon, and I highlighted the error so they won't just put it back on the shelf. I had to call Customer Service, as the default action for the return reason I chose was to ship out a replacement, and I was leary of getting another mismatch. I actually decided to get the Z77 Pro4 instead, for various reasons specific to my use.

    I would still be interested to hear what ASRock has to say, but I suspect they will be getting the board back soon enough.

    Mark

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •