Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 7 of 7

Thread: ASRock Z87 Extreme disappearing drives




  1. #1
    Join Date
    Sep 2013
    Location
    Oregon
    Posts
    4

    Default ASRock Z87 Extreme disappearing drives

    Greetings,
    I have been having an issue with the C drive (Mushkin Enhanced Chronos MKNSSDCR480GB 2.5" 480GB SATA III MLC Internal Solid State Drive) would randomly disappear during reboot. I have to unplug and re plug in the sata cable and it shows up again. I have been blaming the drive for this issue and have been on the Mushkin forums. Yesterday I tried to burn a DVD and that drive disappeared at the end of the burn. This happens every time I try to burn anything. Now I am thinking motherboard issue. Any suggestions?
    Thanks,
    Kirk

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Extreme disappearing drives

    There are seven ASRock Z87 Extreme boards, which one is yours?

    Which SATA ports are you using, Intel or ASMedia?

    What OS are you using, and Storage Configuration BIOS settings? Very short on information here...

  3. #3
    Join Date
    Sep 2013
    Location
    Oregon
    Posts
    4

    Default Re: ASRock Z87 Extreme disappearing drives

    Sorry, I thought all of that would show up from the profile I created.

    Motherboard: ASRock Z87 Extreme4 LGA 1150 Intel Z87 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
    SATA Ports: I don't know. I am a bit of a newbie and my friend built the computer for me. Is this something I can find in the BIOS?
    C Drive: Mushkin Enhanced Chronos MKNSSDCR480GB 2.5" 480GB SATA III MLC Internal Solid State Drive (SSD)
    Video Card: MSI Gaming N760 TF 4GD5/OC GeForce GTX 760 4GB 256-bit GDDR5 PCI Express 3.0 SLI Support Video Card
    Processor: Intel Core i7-4770K Haswell 3.5GHz LGA 1150 84W Quad-Core Desktop Processor Intel HD Graphics BX80646I74770K
    RAM: Mushkin Enhanced Redline 32GB (4 x 8GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model 994070
    Power Supply: COOLER MASTER eXtreme Power Plus RS700-PCAAE3-US 700W ATX 12V v2.3 Active PFC Power Supply

    Below is copied from Windows System Information. I truly appreciate your looking at my problem.

    OS Name Microsoft Windows 7 Professional
    Version 6.1.7601 Service Pack 1 Build 7601
    Other OS Description Not Available
    OS Manufacturer Microsoft Corporation
    System Name BENDSUITE
    System Manufacturer To Be Filled By O.E.M.
    System Model To Be Filled By O.E.M.
    System Type x64-based PC
    Processor Intel(R) Core(TM) i7-4770K CPU @ 3.50GHz, 3501 Mhz, 4 Core(s), 8 Logical Processor(s)
    BIOS Version/Date American Megatrends Inc. P2.30, 7/3/2013
    SMBIOS Version 2.7
    Windows Directory C:\Windows
    System Directory C:\Windows\system32
    Boot Device \Device\HarddiskVolume3
    Locale United States
    Hardware Abstraction Layer Version = "6.1.7601.17514"
    User Name BendSuite\Kirk
    Time Zone Pacific Daylight Time
    Installed Physical Memory (RAM) 32.0 GB
    Total Physical Memory 31.9 GB
    Available Physical Memory 29.1 GB
    Total Virtual Memory 63.9 GB
    Available Virtual Memory 60.9 GB
    Page File Space 31.9 GB
    Page File C:\pagefile.sys


    Below is the Conflicts/Sharing from Hardware Resources




    I/O Port 0x00000000-0x0000001F Direct memory access controller
    I/O Port 0x00000000-0x0000001F PCI bus

    Memory Address 0xF3100000-0xF31FFFFF PCI standard PCI-to-PCI bridge
    Memory Address 0xF3100000-0xF31FFFFF Texas Instruments 1394 OHCI Compliant Host Controller
    Memory Address 0xF3100000-0xF31FFFFF Intel(R) 82801 PCI Bridge - 244E

    I/O Port 0x000003C0-0x000003DF NVIDIA GeForce GTX 760
    I/O Port 0x000003C0-0x000003DF Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01

    I/O Port 0x00000065-0x0000006F Motherboard resources
    I/O Port 0x00000065-0x0000006F Motherboard resources

    I/O Port 0x00000070-0x00000077 System CMOS/real time clock
    I/O Port 0x00000070-0x00000077 Motherboard resources

    Memory Address 0xE8000000-0xEFFFFFFF NVIDIA GeForce GTX 760
    Memory Address 0xE8000000-0xEFFFFFFF Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01

    I/O Port 0x000004D0-0x000004D1 Motherboard resources
    I/O Port 0x000004D0-0x000004D1 Programmable interrupt controller

    I/O Port 0x0000E000-0x0000E07F NVIDIA GeForce GTX 760
    I/O Port 0x0000E000-0x0000E07F Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01

    Memory Address 0xFF000000-0xFFFFFFFF Motherboard resources
    Memory Address 0xFF000000-0xFFFFFFFF Intel(R) 82802 Firmware Hub Device

    IRQ 16 Intel(R) Management Engine Interface
    IRQ 16 NVIDIA GeForce GTX 760
    IRQ 16 Intel(R) 8 Series/C220 Series PCI Express Root Port #1 - 8C10
    IRQ 16 Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01
    IRQ 16 Intel(R) 8 Series/C220 Series USB EHCI #2 - 8C2D

    IRQ 18 Asmedia 106x SATA Controller
    IRQ 18 Intel(R) 8 Series/C220 Series PCI Express Root Port #3 - 8C14
    IRQ 18 PCI standard PCI-to-PCI bridge

    Memory Address 0xA0000-0xBFFFF NVIDIA GeForce GTX 760
    Memory Address 0xA0000-0xBFFFF PCI bus
    Memory Address 0xA0000-0xBFFFF Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01

    I/O Port 0x000003B0-0x000003BB NVIDIA GeForce GTX 760
    I/O Port 0x000003B0-0x000003BB Intel(R) Xeon(R) processor E3-1200 v3/4th Gen Core processor PCI Express x16 Controller - 0C01

    Memory Address 0xF3200000-0xF32001FF Asmedia 106x SATA Controller
    Memory Address 0xF3200000-0xF32001FF Intel(R) 8 Series/C220 Series PCI Express Root Port #3 - 8C14

    I/O Port 0x00000080-0x00000080 Motherboard resources
    I/O Port 0x00000080-0x00000080 Motherboard resources

    I/O Port 0x0000FFFF-0x0000FFFF Motherboard resources
    I/O Port 0x0000FFFF-0x0000FFFF Motherboard resources
    I/O Port 0x0000FFFF-0x0000FFFF Motherboard resources

    I/O Port 0x0000D000-0x0000D01F Asmedia 106x SATA Controller
    I/O Port 0x0000D000-0x0000D01F Intel(R) 8 Series/C220 Series PCI Express Root Port #3 - 8C14

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Extreme disappearing drives

    Sorry too, the profile option does not work consistently for some reason, not sure why.

    The information you put in your post is great, thanks for that. But it did not answer my question, sorry to say.

    Yes you can check the BIOS for the location of your SSD. Go to the Advanced screen, and then Storage Configuration, which will look similar to this:

    ASRock Z87 Extreme disappearing drives-z87-uefi-storage-config-jpg

    The entries for SATA3_0 through SATA3_5 are all the Intel SATA ports.

    The entries for SATA3_A1 and SATA3_A2/eSATA1 are the ASMedia SATA ports. (NOTE: Your board has two ASMedia SATA ports, my board has four, so you won't see the others I have.)

    You should see your Mushkin SSD listed on the same line as the port it is connected to. The "INTEL..." you see in the picture are the drives I'm using, that does not identify them as Intel SATA ports, we can only go by those port IDs. "Not detected" means nothing is connected to that port, or the drive has problems.

    When you check this, also check that the option "SATA Aggressive Link Power Management" is set to Disabled, since that can cause problems if enabled.

    There are other reasons that might cause the problem you have, but we need to know where your SSD is connected first.

  5. #5
    Join Date
    Sep 2013
    Location
    Oregon
    Posts
    4

    Default Re: ASRock Z87 Extreme disappearing drives

    Thanks so much, I truly appreciate all of your help. One more issue I have been having is whenever I turn on my dock via esata the computer completely freezes. The same dock works fine via usb.


    ASRock Z87 Extreme disappearing drives-bios-jpg

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: ASRock Z87 Extreme disappearing drives

    The eSATA with the ASMedia SATA controller seems rather flaky, and is hard to diagnose the issue. I will say you should not have your DVD drive on the ASMedia ports, which might be causing your freezing issue, but that is just a guess. If you can set the eSATA port to Enabled rather than Auto as seen in your screen shot, that might help.

    Your SSD as your OS drive is best put on the Intel SATA 0 port, and I would also move the DVD drive to an Intel SATA port.

    Also, is your disappearing SSD still a problem?

  7. #7
    Join Date
    Sep 2013
    Location
    Oregon
    Posts
    4

    Red face Re: ASRock Z87 Extreme disappearing drives

    I did everything you suggested and so far so good . We will see on the C drive...it has been inconsistent in it's disappearing, today has been all good though. I will let you know if it continues.
    Thanks again!!!!!
    Kirk

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •