Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: PCI Express Active-State Power Management (ASPM) Disabled




  1. #1
    Join Date
    Sep 2013
    Location
    United States
    Posts
    1

    Unhappy PCI Express Active-State Power Management (ASPM) Disabled

    PCI Express Active-State Power Management (ASPM) Disabled. This error message appears in Powercfg -energy report. It appears to be causing my PC to not enter sleep mode as per Power Config settings. Which are set to sleep when PC is idle for 30 minutes. I have reviewed all of the suggestion in the Windows 7 Forum and none of those suggestions work. Does anyone know how to fix this problem?

  2. #2
    Join Date
    Sep 2002
    Location
    Secret Bunker
    Posts
    140

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Most likely you or someone disabled the feature in the BIOS. I would look there first.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Quote Originally Posted by jtc1150 View Post
    PCI Express Active-State Power Management (ASPM) Disabled. This error message appears in Powercfg -energy report. It appears to be causing my PC to not enter sleep mode as per Power Config settings. Which are set to sleep when PC is idle for 30 minutes. I have reviewed all of the suggestion in the Windows 7 Forum and none of those suggestions work. Does anyone know how to fix this problem?
    When is an error not an error? Depends on what is judging what an error is and why.

    The Powercfg energy report is biased towards anything that is not in a power saving mode or configuration as an error. If your board's BIOS allows you to set the speed of the PCI-E slots, as in "PCI-E 2.0" or "PCI-E 3.0", then that locks them at that speed, or should do so. When set to "Auto" with modern video cards, under low demand situations (browsing the Internet, not gaming), the PCI-E speed will downshift to PCI-E 1.0 speed, even with a board and video card that supports PCI-E 3.0.

    Next, the Windows Power Plan has an Advanced option under "PCI Express" called "Link State Power Management", that can be set to Off, Moderate, or Maximum power savings. It sounds like that is set to Off on your board, or the settings in your BIOS are not set to Auto as I described above, or both.

    Which one of these causes the Powercfg report to flag an "error"? Or is it both? I don't know.

    I'm having a Sleep problem myself, I enter Sleep and the board wakes within seconds, when previously that would not happen. I tried setting the PCI-E speed to Auto in the BIOS, and set that Power Plan setting to Maximum power savings, and it did not fix it. It might work for you, so well worth a try.

    Sleep issues can be very difficult to fix. In my case, I think it was caused by either installing or using some software (Samsung's disk cloning tool for their SSDs), as AFAIK the problem started after I installed and used it. I removed it and the problem remains. I suspect that some internal setting or registry entry that was not changed back when that software was uninstalled is causing the problem, but I'm not certain. The problem happens with the newly cloned SSD too. I have yet to try a full BIOS/UEFI clear by removing the board's battery. If that fails, then that indicates IMO that it is a Windows setting... somewhere...

  4. #4
    ProBackup-nl is offline Junior Member
    Join Date
    Aug 2014
    Location
    NL
    Posts
    13

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Even with the PCI-E speed to Auto in the firmware/BIOS the ASRock H81 Pro BTC P1.80 firmware actively disables PCI Express Active-State Power Managment (ASPM).

    Despite that the default Ubuntu 14.04 requires the version 8.038 of the r8168-dkms package (currently only in Utopic repository) to allow the processor to go in to package state C6 (pc6) for the RTL8111GR onboard device, another requirement is that ASPM is Enabled.

    However even boot parameter pcie_aspm=force doesn't enable ASPM for the H81 Pro BTC P1.80, where enabling the PCI registers manually does enable ASPM, makes the Celeron G1820 processor go in to PC6 and lowers the idle power consumption by 8 till 14 watts:
    Code:
    # cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-3.13.0-35-generic root=/dev/sda1 ro intel_pstate=enable ipv6.disabled=1 pcie_aspm=force debug ignore_loglevel crashkernel=384M-:128M
    # lspci -vvvv | grep ASPM
            LnkCap:    Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
            LnkCtl:    ASPM Disabled; RCB 64 bytes Disabled- CommClk-
            LnkCap:    Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
            LnkCtl:    ASPM Disabled; RCB 64 bytes Disabled- CommClk-
            LnkCap:    Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
            LnkCtl:    ASPM Disabled; RCB 64 bytes Disabled- CommClk+
            LnkCap:    Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
            LnkCtl:    ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    # setpci -s 00:01.00 0xB0.B=0x3
    # setpci -s 00:1c.0 0x50.B=0x43
    # setpci -s 00:1c.05 0x50.B=0x43
    # setpci -s 03:00.0 0x80.B=0x43
    # lspci -vvvv | grep ASPM
            LnkCap:    Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
            LnkCtl:    ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk-
            LnkCap:    Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <256ns, L1 <4us
            LnkCtl:    ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
            LnkCap:    Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
            LnkCtl:    ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
            LnkCap:    Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
            LnkCtl:    ASPM L0s L1 Enabled; RCB 64 bytes Disabled- CommClk+
    Note: The setpci command is closely hardware related. I expect that can't copy and paste these parameters when you are not running identical hardware and firmware. There is a manual how to find the correct parameters for your device: ASPM - Linux Wireless and a handy script at http://drvbp1.linux-foundation.org/~...ts/enable-aspm (although I couldn't manage how to find the ROOT_COMPLEX to I filled in identical values at both ROOT_COMPLEX and ENDPOINT).

    Another proof that ASPM is actively disabled in ASRock its firmware:
    Code:
    # dmesg | grep ASPM
    [    0.084410] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
    [    0.126068] acpi PNP0A08:00: Disabling ASPM (FADT indicates it is unsupported)

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    I've noticed that an Auto setting in ASRock BIOS/UEFI firmware behaves in whatever manner the designers choose, which may not match what we expect it to do.

    Do rules or standards for an Auto setting for a firmware option exist?

    Even if there is a standard, a particular board may have its Auto option settings biased for the specific use of that board. For example your H81 Pro BTC board has PCI Express Active-State Power Management disabled on Auto, because the designers decided that a Bit Coin mining board and its users would want full performance at all times. That may not make logical sense to you and in reality, but other users might think full performance regardless of load is better.

    I noticed that an Auto setting for CPU C States seemed to leave them disabled on my (different) ASRock boards. That was also true for the FIVR Efficiency Mode option, an Auto setting disabled it.

    I don't trust Auto settings to do what I want them to do, and always choose enabled if I want an option enabled.

  6. #6
    ProBackup-nl is offline Junior Member
    Join Date
    Aug 2014
    Location
    NL
    Posts
    13

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Quote Originally Posted by parsec View Post
    For example your H81 Pro BTC board has PCI Express Active-State Power Management disabled on Auto
    I do wish that this Asrock H81 Pro BTC board firmware/BIOS has a "PCI Express Active-State Power Management" setting. The issue is that there is not such setting in version P1.80 neither P1.80A. There is only PCIE2 Link Speed in the "Chipset Configuration".

    The result is that with a default Ubuntu 14.04 Linux kernel and no special kernel boot parameters, the idle power consumption is 11.73kWh per month (30 days). After enabling PCIe active state manually (using setpci) for all 4 PCIe devices and implementing all powertop suggestions the idle power consumption is 8.35kWh: a reduction in energy usage of almost 28%.

    With Linux kernel 3.13 the boot parameters pcie_aspm.policy=powersave doesn't improve L0s enablement, pcie_aspm=force enables L0s on the Realtek device, while combining pcie_aspm=force pcie_aspm.policy=powersave results in L0s on 3 devices out of 4.

    The results and devices:
    Code:
    # lspci -s 00:01.00 -nn
    00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller [8086:0c01] (rev 06)
    # lspci -s 00:1c.00 -nn
    00:1c.0 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 [8086:8c10] (rev d5)
    # lspci -s 00:1c.05 -nn
    00:1c.5 PCI bridge [0604]: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #6 [8086:8c1a] (rev d5)
    # lspci -s 03:00.00 -nn
    03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 11)
    ===
    	LnkCap:	Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    	LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    pcie_aspm.policy=powersave
    	LnkCap:	Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    	LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    pcie_aspm=force
    	LnkCap:	Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk+
    	LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk+
    pcie_aspm=force pcie_aspm.policy=powersave
    	LnkCap:	Port #2, Speed 5GT/s, Width x16, ASPM L0s L1, Exit Latency L0s <1us, L1 <8us
    	LnkCtl:	ASPM Disabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk-
    	LnkCap:	Port #6, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <512ns, L1 <16us
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk+
    	LnkCap:	Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <
    	LnkCtl:	ASPM L0s Enabled; RCB 64 bytes Disabled- CommClk+
    Last edited by ProBackup-nl; 09-11-2014 at 03:58 AM. Reason: boot option results for pcie_aspm=force and/or pcie_aspm.policy=powersave inserted

  7. #7
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Quote Originally Posted by ProBackup-nl View Post
    I do wish that this Asrock H81 Pro BTC board firmware/BIOS has a "PCI Express Active-State Power Management" setting.
    Not throwing salt in your wounds yet I see it as you simply bought the wrong board for the purpose. Miners using the mining specific BTC boards would have no use for ASPM in the setup/BIOS. Quite the contrary. They would care less and in fact be considered as useless as **** on a boar hog on a dedicate mining rig.

    Quote Originally Posted by ProBackup-nl View Post
    The issue is that there is not such setting in version P1.80 neither P1.80A.
    If your board can yet be returned for exchange, that's what I would do. I'd get a main stream board with the proper bells and whistles to run a server or desktop. But what you have now is for mining, short and simple.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  8. #8
    ProBackup-nl is offline Junior Member
    Join Date
    Aug 2014
    Location
    NL
    Posts
    13

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    We can't use the Asrockrack options because those main boards have a minimal 30 seconds boot slow down due to the Aspeed BMC controller.

    Many other Asrock boards have ASPM disabled, see below.

    Which proper socket 1150 board would you suggest?





  9. #9
    ProBackup-nl is offline Junior Member
    Join Date
    Aug 2014
    Location
    NL
    Posts
    13

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Luckily firmware/BIOS 1.80b for H81 Pro BTC opens all ASPM options (under
    Chipset Configuration):
    • Native ASPM [Default: Disabled] - On enable, Vista will control the ASPM support for the device. If disabled, the BIOS will.
    • PEG0 - ASPM [Default: ASPM L0sL1] - Control ASPM support for the PEG Device. This has no effect if PEG is not the currently active device.
    • ASPM L0s [Default: Both Root and Endpoint ports] - Enable PCIe ASPM L0s.
    • PEG1 - ASPM [Default: Disabled] - Control ASPM support for the PEG Device. This has no effect if PEG is not the currently active device.
    • ASPM L0s [Default: Both Root and Endpoint ports] - Enable PCIe ASPM L0s.
    • PEG2 - ASPM [Default: Disabled] - Control ASPM support for the PEG Device. This has no effect if PEG is not the currently active device.
    • ASPM L0s [Default: Both Root and Endpoint ports] - Enable PCIe ASPM L0s.
    • Program PCIe ASPM after OpROM [Default: Disabled] - Enabled: PCIe ASPM will be programmed after OpROM. Disabled: PCIe ASPM will be programmed before OpROM.
    • DMI Link ASPM Control [Default: Disabled] - Enable or disable the control of Active State Power Management on SA side of the DMI Link.


    Note: PEG = PCI Express Graphics

    PCI Express Active-State Power Management (ASPM) Disabled-p1-80b-aspm-settings-jpg

  10. #10
    ProBackup-nl is offline Junior Member
    Join Date
    Aug 2014
    Location
    NL
    Posts
    13

    Default Re: PCI Express Active-State Power Management (ASPM) Disabled

    Despite the new P1.80B firmware/BIOS version, where ASMP can be enabled in the setup utility, the ACPI FADT doesn't seem to match these settings:

    Code:
    # dmesg | grep ASPM
    [    0.082290] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
    [    0.114380] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI]
    [    0.123717] acpi PNP0A08:00: Disabling ASPM (FADT indicates it is unsupported)
    Whether "Program PCIe ASPM after OpROM" is enabled or disabled doesn't matter.PCI Express Active-State Power Management (ASPM) Disabled-program-pcie-aspm-oprom-jpg

    The FADT/FACP still list that ASPM is not supported, while ASPM is enabled in UEFI firmware setup utility:
    Code:
    # fwts acpidump -
    
    [0x06d 0109   2]             IA-PC Boot Flags (see below): 0x0012
                                Legacy Devices Supported (V2): 0x0
                             8042 present on ports 60/64 (V2): 0x1
                                         VGA Not Present (V4): 0x0
                                       MSI Not Supported (V4): 0x0
                                 PCIe ASPM Not supported (V4): 0x1
                                    CMOS RTC Not Present (V5): 0x0
    Full fwts acpidump output: fwts acpidump output for Asrock H81 Pro BTC Linux 3.13 - Pastebin.com
    Last edited by ProBackup-nl; 09-13-2014 at 04:40 AM. Reason: FADT/FACP output appended

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 27 users browsing this thread. (0 members and 27 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •