Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?




  1. #1
    Join Date
    Oct 2013
    Location
    suomi
    Posts
    2

    Default How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?

    Hello,

    I've tried everything, but I can't figure out a way to disable read panel audio jack detection in Z68 Extreme4 Gen3. The board looses my mic from time to time which in turn crashes some games
    dependent on it, Planetside 2, for example.

    Does anyone know a way to disable it? I'd be eternally thankful!


    - Trokari

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?

    Quote Originally Posted by Trokari View Post
    Hello,

    I've tried everything, but I can't figure out a way to disable read panel audio jack detection in Z68 Extreme4 Gen3. The board looses my mic from time to time which in turn crashes some games
    dependent on it, Planetside 2, for example.

    Does anyone know a way to disable it? I'd be eternally thankful!


    - Trokari
    I don't understand, you want to disable the rear panel audio jacks, including the microphone input, which you need for games, but it causes the game to crash?

    How do you know that is what is causing the game to crash?

    Your BIOS may have a setting to do this, but don't forget that disabling the board's audio on the back panel may affect the front panel jacks too.

    My ASR board's BIOS has two settings in the South Bridge screen to configure the onboard audio:

    Onboard HD Audio and Front Panel. They can be enabled, disable, and set to auto which disables them when a sound card is used.

    You'll need to experiment with them to see if they will do what you want them to do.

    Otherwise, in Windows Device Manager you can disable audio devices, but that will stop all audio support, not just microphones.

  3. #3
    profJim's Avatar
    profJim is online now Chief Munchkin + moderator
    Join Date
    Dec 2008
    Location
    Tacoma, WA. [USA]
    Posts
    7,811

    Default Re: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?

    Welcome to the forum.
    Quote Originally Posted by Trokari View Post
    I've tried everything, but I can't figure out a way to disable read panel audio jack detection in Z68 Extreme4 Gen3.
    ....snip....
    - Trokari
    The thread title is: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?
    He doesn't want to disable the rear audio jacks, he wants to disable jack detection only for the rear audio jacks.

    We don't know which audio jacks he is using; rear audio? front HD audio? AC'97?

    Page 10 in the mobo user manual says:
    8. For microphone input, this motherboard supports both stereo and mono
    modes. For audio output, this motherboard supports 2-channel, 4-channel,
    6-channel, and 8-channel modes. Please check the table on page 14
    for proper connection.
    Page 40 says:
    1. High Definition Audio supports Jack Sensing, but the panel wire on the chassis must support HDA to function correctly.
      Please follow the instruction in our manual and chassis manual to install your system.
    2. If you use AC’97 audio panel, please install it to the front panel audio header as below:
    A. Connect Mic_IN (MIC) to MIC2_L.
    B. Connect Audio_R (RIN) to OUT2_R and Audio_L (LIN) to OUT2_L.
    C. Connect Ground (GND) to Ground (GND).
    D. MIC_RET and OUT_RET are for HD audio panel only. You don’t need to connect them for AC’97 audio panel.
    E. To activate the front mic.
    For Windows® XP / XP 64-bit OS:
    Select “Mixer”. Select “Recorder”. Then click “FrontMic”.
    For Windows® 7 / 7 64-bit / VistaTM / VistaTM 64-bit OS:
    Go to the "FrontMic" Tab in the Realtek Control panel. Adjust “Recording Volume”.

    I haven't used Realtek audio for years and don't recall if you disable jack detection if this affects front panel audio jack detection.
    I vaguely remember something about a yellow "folder" icon near the upper right corner of the Realtek software control panel.
    Last edited by profJim; 10-03-2013 at 05:47 PM.
    Q9650 @ 4.10GHz [9x456MHz]
    P35-DS4 [rev: 2.0] ~ Bios: F14
    4x2GB OCZ Reaper PC2-8500 1094MHz @5-5-5-15
    MSI N460GTX Hawk Talon Attack (1GB) video card <---- SLI ---->
    Seasonic SS-660XP2 80 Plus Platinum psu (660w)
    WD Caviar Black WD6401AALS 640GB (data)
    Samsung 840 Pro 256GB SSD (boot)
    SLI @ 16/4 works when running HyperSLI
    Cooler Master 120XL Seidon push/pull AIO cpu water cooling
    Cooler Master HAF XB computer case (RC-902XB-KKN1)
    Asus VH242H 24" monitor [1920x1080]
    MSI N460GTX Hawk (1GB) video card
    Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium
    HT|Omega Claro plus+ sound card
    CyberPower CP1500PFCLCD UPS
    E6300 (R0) @ 3.504GHz [8x438MHz] ~~ P35-DS3L [rev: 1.0] ~ Bios: F9 ~~ 4x2GB Kingston HyperX T1 PC2-8500, 876MHz @4-4-4-10
    Seasonic X650 80+ gold psu (650w) ~~ Xigmatek Balder HDT 1283 cpu cooler ~~ Cooler Master CM 690 case (RC-690-KKN1-GP)
    Samsung 830 128GB SSD MZ-7PC128B/WW (boot) ~~ WD Caviar Black WD6401AALS 640GB (data) ~~ ZM-MFC2 fan controller
    HT|Omega Striker 7.1 sound card ~~ Asus VH242H monitor [1920x1080] ~~ Logitech Z-5500 Digital 5.1 Speakers
    win7 x64 sp1 Home Premium ~~ CyberPower CP1500PFCLCD U.P.S
    .


  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?

    Quote Originally Posted by profJim View Post
    Welcome to the forum.
    The thread title is: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?
    He doesn't want to disable the rear audio jacks, he wants to disable jack detection only for the rear audio jacks.

    We don't know which audio jacks he is using; rear audio? front HD audio? AC'97?

    ...

    I haven't used Realtek audio for years and don't recall if you disable jack detection if this affects front panel audio jack detection.
    I vaguely remember something about a yellow "folder" icon near the upper right corner of the Realtek software control panel.
    True, and the Realtek software on my ASR Z87 board only allows jack detection for the front panel audio jacks to be disabled. That is the yellow folder icon you mentioned.

    Or I can mute the rear output device when one is plugged into the front panel jack(s).

    The OP's software may be different than mine. I don't see anything in the Windows Sound options to disable jack detection.

    I still don't understand what the OP wants to happen overall.

  5. #5
    Join Date
    Oct 2013
    Location
    suomi
    Posts
    2

    Default Re: How to disable rear audio panel jack detection in Z68 Extreme4 Gen3 ?

    Thank you all for replying! I'm sorry I haven't gotten back sooner.

    I'm using the back panel audio connectors, green and pink. I have a gamind headset connected there.
    I also have my Cooler Master HAF-X 's font panel mic and speakers connected to the MB, altho when I tried I could not get the front panel mic
    working. However the Realtek HD audio manager immediately detected that I plugged in a Front mic, so it's working on some level.

    Similar detection happens in the rear panel mic jack. I'll try to clarify the problem further.

    Sometimes (really often now) the rear panel mic connector "looses" the microphone. When this happens and in Windows 7 you right click the white speaker icon and choose
    "Recording devices", the Microphone (refers to rear panel mic) is shown as "Not connected" and the FrontMic is connected altho there is nothing connected there.

    If you now unplug and plug the mic connected to rear panel connector, the Microphone gets detected (green check mark). However, sometimes the FrontMic gets detected again and Real panel mic disconnected
    after a random period of time. Sometime it might be right after detecting the re-plugged rear panel mic.

    With some unplugging and re-plugging, I might get the rear panel mic to stick as detected. Now when the rear panel mic is lost during playing PS2 for example, the game crashed immediately,
    which is quite annoying to say the least.
    This is the reason why I would like to find a way to disable whatever the Realtek drivers are doing to sense the mic jack, be it jack detection something else. I would like the
    mic jacks to be plain dummy jacks which are forced on no matter if something is plugged in there or not. I don't even know if this is possible tho.

    Next I'm going to try and disconnect the Front audio panel from the Mobo in case it's not compatible somehow and causes this hassle. I'm still open to any and all ideas you might have regarding this.


    - Trokari

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •