Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 5 of 5

Thread: b85m-itx Wake On LAN not working - Bios problem?




  1. #1
    Join Date
    Oct 2013
    Location
    nyc
    Posts
    2

    Default b85m-itx Wake On LAN not working - Bios problem?

    Hello. I just setup a b85m-itx and installed Ubuntu Server 13.04 but I can't seem to get Wake on Lan working. I have all the settings within the server system set correctly and set the BIOS to allow/enable wake up events via LAN. When I suspend the machine (into S3 state), the NIC lights go off. Is it supposed to do that?

    I have disabled deep sleep and S5-S6 states as well.

    Any thoughts? I am able to receive the magic packets when the server is on (verified by wireshark the incoming packets) but I think when it's off the NIC is completely powered off despite the BIOS settings.

    I'm almost positive everything is set correctly in Ubuntu. /proc/apci/wakeup has the proper pci bus and ethernet card enabled. ethtools wol is set to 'g'. I can let you know the settings if you're interested but it seems like it's a bios problem.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: b85m-itx Wake On LAN not working - Bios problem?

    I'm not a Ubuntu/Linux person, but I can tell you that on my ASRock Z77 and Z87 boards, the NIC LEDs are on when the PC is shutdown in Windows, which is S5 state. Actually, I can have the PSU turned off and unplugged from AC power to work on the PC, and when I plug in the PSU and turn the PSU switch on (but nothing more), the NIC LEDs come on. That's what I use now to check that the board is getting power, not the power LED on the board itself.

    Windows has a Power Management option for NICs that enable it to remain awake for WOL, etc. It could be a BIOS problem, but also might be a driver problem.

    Your board's Qualcomm Atheros AR8171 NIC chip might not have enough support from Ubuntu. I notice your NIC has "Supports Qualcomm Atheros Security Wake On Internet Technology", whch might have some odd configuration needed.

  3. #3
    Join Date
    Oct 2013
    Location
    nyc
    Posts
    2

    Default Re: b85m-itx Wake On LAN not working - Bios problem?

    So, after fiddling some more, you're right, the NIC LEDs need to be on. When I hibernate Ubuntu, the NIC lights stay on and I am able to WOL. However, that is no good for me since the encryption I am using requires entering the passkey onsite so I can't do that. On comparison of the hibernation and suspend routines I noticed that on suspend, it does a 'modunload alx' which are the drivers for the atheros NIC. Commenting it out did the trick and the lights stayed on when I suspend and now I can WOL. HOWEVER, I discovered the reason for the modunload alx is due to a bug that prevents the machine from suspending properly, hence they added that line in. SO, now I'm able to WOL from suspend but I can't suspend the machine properly. So my original issue is fixed but now I have a different one. Interestingly enough, hibernation works fine and WOL from hibernation works everytime. Just can't suspend and WOL and suspend again. First suspend works, but after that, it does not anymore. Anyways, just wanted to update in case any one is searching and needs an answer. What I did was commented out:
    Code:
    modunload alx && echo Done. || echo Failed.
    within /usr/lib/pm-utils/sleep.d/50unload_alx and it left the NIC lights on after suspension which enabled WOL.
    Quote Originally Posted by parsec View Post
    I'm not a Ubuntu/Linux person, but I can tell you that on my ASRock Z77 and Z87 boards, the NIC LEDs are on when the PC is shutdown in Windows, which is S5 state. Actually, I can have the PSU turned off and unplugged from AC power to work on the PC, and when I plug in the PSU and turn the PSU switch on (but nothing more), the NIC LEDs come on. That's what I use now to check that the board is getting power, not the power LED on the board itself. Windows has a Power Management option for NICs that enable it to remain awake for WOL, etc. It could be a BIOS problem, but also might be a driver problem. Your board's Qualcomm Atheros AR8171 NIC chip might not have enough support from Ubuntu. I notice your NIC has "Supports Qualcomm Atheros Security Wake On Internet Technology", whch might have some odd configuration needed.

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: b85m-itx Wake On LAN not working - Bios problem?

    Glad you made some progress on your problem. I always like it when a savvy user discovers an issue with code and can work around it, even if the work around reveals another problem. Just shows how difficult code/programs can be, with all the interactions it must deal with. Keep after it, you might find a way to fix it permanently.

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: b85m-itx Wake On LAN not working - Bios problem?

    I found the following in an ASRock FAQ, not sure if it will help you at all, but who knows? See question 3:


    http://www.asrock.com/support/QA/TSDQA-104.pdf

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •