Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Asrock H87M Pro4, Wake on Lan dont work




  1. #11
    Join Date
    Dec 2013
    Location
    Singapore
    Posts
    7

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    i have the exact same problem .. I have been trying to remote switch on the PC for 2 days and couldn't solve it, am using the latest drivers from Asrock website, checked the required settings, upgrade the BIOS ... remote shutdown and remote reset features work via Meshcentral but not remote boot up

  2. #12
    Join Date
    Dec 2013
    Location
    Singapore
    Posts
    7

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    I was told that the Wake On Lan only works on PC at Suspend Mode ... and not PC already shutdown .. is this correct? Does anyone know ?

  3. #13
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    No, WOL should work from a shutdown, since the PSU is on and the mother board has power, and the LAN chip should be active in that situation.

    Are you using Windows 8? The Intel LAN driver is known to have a WOL issue with Windows 8. Are you using the Intel LAN driver from your board's download page or the driver disk?

    You said you had things configured correctly, WOL enabled in the BIOS? WOL enabled in the Device Manager entry for the Intel LAN chip?

  4. #14
    Join Date
    Dec 2013
    Location
    Singapore
    Posts
    7

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    Actually after doing more research, seems that Intel Remote Wake does NOT work on Hibernate and Shutdown

    Intel® 4 Series Chipset Boards — Intel® Remote Wake Technology technical support

    Quote
    Troubleshooting
    Program does not wake computer
    Possible causes and solutions to this problem include the following:

    The PC does not support Intel RWT.
    Third party software is not enabled for Intel RWT. Check your program’s documentation to verify that it supports Intel RWT.
    Intel RWT requires a wired Ethernet connection from the PC to the broadband modem/router to operate correctly. Make sure your Intel RWT supported PC is configured properly.
    The PC may be in hibernate or shutdown preventing remote wake. Set PC to sleep mode. To manually put your computer to sleep: click Start, click the arrow next to the Lock button, and then select Sleep.

    UnQuote

  5. #15
    Join Date
    Dec 2013
    Location
    Singapore
    Posts
    7

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    Ok .. i got reply from Asrock support which confirms that PC can only remote wake from Sleep or Hibernate ... but strangely, the Remote Wake still does NOT work on MeshCentral but Remote Wake works on Splashtop ...


    I'm assuming that they are using magic packet to wake the PC so MeshCentral's magic packet might have some problems that Intel Remote Wake is not recognizing .






    Quote"


    Thank you for contacting ASRock.





    Please kindly note that Remote Wake feature is supported in S3/S4 mode.


    The "Power off" of Meshcentral will let the system go to S5 sate instead of S3/S4.


    So that it will not be able to waken after the proedure.


    Please kindly use "Hibernate" or "Sleep" instead.





    Thanks for your e-mail.





    Good Day,


    ASRock TSD

  6. #16
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    Quote Originally Posted by zhix View Post
    Actually after doing more research, seems that Intel Remote Wake does NOT work on Hibernate and Shutdown

    Intel® 4 Series Chipset Boards — Intel® Remote Wake Technology technical support

    Quote
    Troubleshooting
    Program does not wake computer
    Possible causes and solutions to this problem include the following:

    The PC does not support Intel RWT.
    Third party software is not enabled for Intel RWT. Check your program’s documentation to verify that it supports Intel RWT.
    Intel RWT requires a wired Ethernet connection from the PC to the broadband modem/router to operate correctly. Make sure your Intel RWT supported PC is configured properly.
    The PC may be in hibernate or shutdown preventing remote wake. Set PC to sleep mode. To manually put your computer to sleep: click Start, click the arrow next to the Lock button, and then select Sleep.

    UnQuote
    You're going by what is stated for an Intel 4 series chipset board, from the socket 775 era? That is pre-Windows 7. You're using an 8 series chipset, four generations later. The NIC chip on the Z87 and the I217 interface chip did not exist at the time of the 4 series chipsets.

    This is an excerpt from the Release Notes for the latest Intel NIC driver, 18.7:

    Power Management and System Wake
    ================================

    Not all systems support every wake setting. There may be BIOS or Operating
    System settings that need to be enabled for your system to wake up. In
    particular, this is true for Wake from S5 (also referred to as Wake from power off).
    Which means it works on some systems.

    Microsoft Windows 7 and Windows Server 2008 R2 do not support Wake on
    directed packet. Systems with these operating systems will not wake on a
    ping or other directed packet.

    System does not wake when expected
    ----------------------------------
    Under Microsoft Windows 7 or Windows Server 2008 R2, the system may not wake
    when sent an ARP packet. Forcing your system into Home Networking mode
    (instead of work or public mode) will resolve the issue. You can set the
    network mode during install or from the Networking Control Panel.
    However, if the network is disconnected and reconnected, and a DHCP server
    is not available or if there is no default gateway defined, it appears to
    the operating system that the network is undefined and the OS will reset
    it to public.

    Under Microsoft Windows 8 or Windows Server 2012, the system may not wake even
    though Wake on LAN settings are enabled. Disabling Fast Startup in the
    operating system should resolve the issue.

  7. #17
    Join Date
    Dec 2013
    Location
    Singapore
    Posts
    7

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    It was listed under an active Intel Remote Wake introduction and support page which I assume it means that it's still a valid statement but you do have a point on the supported platforms ... strange why Asrock Support is also telling me that Remote Wake On is supported for SLEEP and HIBERNATE mode ONLY ..




    Quote Originally Posted by parsec View Post
    You're going by what is stated for an Intel 4 series chipset board, from the socket 775 era? That is pre-Windows 7. You're using an 8 series chipset, four generations later. The NIC chip on the Z87 and the I217 interface chip did not exist at the time of the 4 series chipsets.

    This is an excerpt from the Release Notes for the latest Intel NIC driver, 18.7:

    Power Management and System Wake
    ================================

    Not all systems support every wake setting. There may be BIOS or Operating
    System settings that need to be enabled for your system to wake up. In
    particular, this is true for Wake from S5 (also referred to as Wake from power off).
    Which means it works on some systems.

    Microsoft Windows 7 and Windows Server 2008 R2 do not support Wake on
    directed packet. Systems with these operating systems will not wake on a
    ping or other directed packet.

    System does not wake when expected
    ----------------------------------
    Under Microsoft Windows 7 or Windows Server 2008 R2, the system may not wake
    when sent an ARP packet. Forcing your system into Home Networking mode
    (instead of work or public mode) will resolve the issue. You can set the
    network mode during install or from the Networking Control Panel.
    However, if the network is disconnected and reconnected, and a DHCP server
    is not available or if there is no default gateway defined, it appears to
    the operating system that the network is undefined and the OS will reset
    it to public.

    Under Microsoft Windows 8 or Windows Server 2012, the system may not wake even
    though Wake on LAN settings are enabled. Disabling Fast Startup in the
    operating system should resolve the issue.

  8. #18
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock H87M Pro4, Wake on Lan dont work

    Quote Originally Posted by zhix View Post
    It was listed under an active Intel Remote Wake introduction and support page which I assume it means that it's still a valid statement but you do have a point on the supported platforms ... strange why Asrock Support is also telling me that Remote Wake On is supported for SLEEP and HIBERNATE mode ONLY ..
    I would think that ASRock knows what the reality of this is with their hardware. Why systems are different in this regard I don't know.

    The only thing I can think of is the different methods used to cause a WOL, which includes different packet types to make that happen.

    You might be able to find something that helps you in the Release Notes file found on this Intel page:

    https://downloadcenter.intel.com/Det...217-V&lang=eng

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •