Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Ultra Fast Boot error




  1. #1
    Join Date
    Oct 2013
    Location
    Ibiza (Spain)
    Posts
    5

    Default Z87 Extreme 6 Ultra Fast Boot error

    Hello,

    I have an Asrock Z87 Extreme 6 and I am having problems using the Ultra Fast Boot feature.
    I have Windows 8.1 Pro 64bit installed in a Samsung 840 SSD device.
    In UEFI (v.2.10) when I list the "boot option priorities" there always appear as 1st option my Western Digital drive, which has no OS in it. As second option appears another Samsung drive (not the SSD) which also hasn't any OS installed, and as third option it appears a Flash USB drive.
    If I select the settings for my boot drive priorities (menu below "Hard Drive BBS Priorities") a new window pops where I can now select the Samsung 840. Going back to the previous screen and this Samsung 840 SSD remains as 1st option where before was not even selectable.

    Then I select ultra fast boot, but after exiting and saving it just goes back again and again to UEFI, the boot menu says there are no boot devices.

    When I select Fast or Normal boot, the settings have gone back to where the 1st option was the Western Digital drive, and again Samsung SSD 840 does not appear unless I go to the mentioned menu.

    After some research it seems that I didn't install my OS in UEFI mode, as BIOS mode appears as "Legacy" in the msinfo. Can I change this without installing the whole system again? I chose the SSD drive to install Windows the first time, but for some strange reason it wrote the boot partition in a different HDD by Western Digital...


    Any clues?

    Thank you for your help.
    Last edited by Luis Ibz; 10-18-2013 at 10:33 PM. Reason: Adding more info

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Ultra Fast Boot error

    Sure, easy part first. Any time Windows is installed with more drives than just the target OS drive installed, Windows will put the MBR (Master Boot Record) on a drive other than the OS drive. That is fairly well known, and a pain that Windows does that. So always just have the drive you want Windows to be installed on in the PC. You can just remove the power cable from other drives when you do this, no need to remove them.

    That is why your boot order is confused, but yours is worse than usual for some reason, you might have partitions from old Windows installations on other drives too, that adds to the confusion. To fix this, remove the power cable from all other drives besides your SSD OS drive. Then boot from your Windows installation media, disk or USB flash drive. Find and select a Windows Repair, which should put an MBR on the SSD. You should remove the MBR partition(s) from your HDDs before you do this if possible, using Disk Management, or Diskpart in a CMD window if you are familiar with that.

    Changing a standard Windows installation to UEFI booting is difficult if even possible, I've never done that. You really need to install Windows in UEFI booting mode. That usually requires a Windows installation USB drive that is configured for a UEFI installation. Otherwise it may work from a standard Windows 8 installation disk, etc, but you must find and set an option called CSM, which is in the Boot screen in your board's UEFI (I have the same board.) Fast Boot must be set to Disabled at first, and CSM set to Disabled, it is Enabled by default, which causes a standard, non-UEFI booting installation to happen. Either way you install Windows for UEFI booting, you must have CSM set to Disabled, or you won't install in UEFI booting mode.

    Here is a link that will get you started with this if you want to try: UEFI Bootable USB Flash Drive - Create in Windows

    But there is one more major issue to deal with. Do you use a video card, or the on-CPU graphics? Video cards must support what is called "GOP", a UEFI booting thing. If a video card does not support GOP, you'll have no video, and your board's UEFI will display an error. The on-CPU video does support GOP, so works fine UEFI booting.

    Still want to try this? It's not that bad, but involves work.

  3. #3
    Join Date
    Oct 2013
    Location
    Ibiza (Spain)
    Posts
    5

    Default Re: Ultra Fast Boot error

    Wow, just THANKS!

    That was a rich answer! First of all you solved that mystery (for me) of Windows placing the MBR on a different drive. It also happened on my previous computer, and it really is a pain for always I wanted to make a system backup it would necessarily backup two drives.
    This is a completely new computer, and things are already messed up because of this... but thanks to your explanation when i find the time to reinstall everything I'll follow your indications.

    I believe my video card supports GOP (Nvidia GTX 770)... however I don't know to what extent is it worth the whole thing, I don't think all the time I'll save in booting will ever add up to the hours of reinstalling everything. Now Windows takes about 24 secs to start which isn't that bad at all.

    I might just try to build a MBR in my SSD as you say and remove it from the HDD. It will at least solve the huge backups processes.

    Thank you so much for your splendid explanation.

    Kind regards,
    L

  4. #4
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Ultra Fast Boot error

    Thanks for appreciating my reply!

    You are right... well I'm not 100% sure, I know all of the Nvidia 700 series cards can support GOP. I know EVGA made 700 cards do, but from what I can see from checking their forum, MSI 700 series cards do not, without a VBIOS update. Nvidia 600 series cards can be made GOP compliant, but a VBIOS update is required. Earlier cards such as 500 series and anything older than that cannot support GOP, and a VBIOS update won't help. Their VBIOS chips are to small apparently to store the required VBIOS.

    If you ever get another SSD, or you current installation goes bad, you can try a UEFI booting installation. Using Ultra Fast boot, it really is amazing how fast Windows 8 starts. Part of that is a feature of Windows 8 that speeds the boot quite a bit.

  5. #5
    Join Date
    Oct 2013
    Location
    USA
    Posts
    15

    Default Re: Ultra Fast Boot error

    Hey guys this is KILLLING ME, trying to figure out how and what exactly to do. I have the Z87 extreme6 board too and few things making me mental. First off yea I have windows 64 bit pro full install disk of Win 8, evga 680 video card that's been updated bios wise to allow it they sent it to me many months ago. But big thing I'm having issue with is I can't at all find option called CSM in the bios anywhere at all. It's the latest update there is for board and I swear I don't see it in there anywhere at all. So entire thing is for not since you point out it must be turned off. How the heck to I do that when I can't find it. My plan is to turn it off, boot to disk drive with win 8 in it, delete entire drive(samsung 840 pro) then select format using GPT instead of NTFS. Then doing install of win 8, then back to bios turn on ultra fast boot and see what happens. But I can't get it done when I can't find the option in bios....

    Ok so I noticed you said disable fast boot. Ok I did that and yes now I see CSM. So in my plan, should I ..turn fast boot off, turn off CSM then put in win 8 disk in blu ray drive after making it the boot device in bios. I'm basically just want to make sure I get it installed in UEFI. But I can least sort things out now that I can see the option in the bios settings. Man this process is so beyond painful it's retarded.
    Last edited by hdtv00; 10-26-2013 at 04:02 PM.

  6. #6
    Join Date
    Oct 2013
    Location
    USA
    Posts
    15

    Default Re: Ultra Fast Boot error

    Ok so I have confirmed my disk version of win 8 does have efi files and folders on it. So I shouldn't need to make a usb boot non sense. Also now that fast boot is disabled under boot options I see my blu ray drive with win 8 in it listed as UEFI option under boot order so I should be good to go. Cept one thing I'm not entirely clear on is some places I see they say leave a partition 200MB at least but others I see it says to format GPD that you need to have drive only wiped with no partitions , I guess I could try it both ways first the 400MB that's already there left alone. Man I wish there were clear answers to all this, anyone feel free to help. THanks.

  7. #7
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Ultra Fast Boot error

    Quote Originally Posted by hdtv00 View Post
    Hey guys this is KILLLING ME, trying to figure out how and what exactly to do. I have the Z87 extreme6 board too and few things making me mental. First off yea I have windows 64 bit pro full install disk of Win 8, evga 680 video card that's been updated bios wise to allow it they sent it to me many months ago. But big thing I'm having issue with is I can't at all find option called CSM in the bios anywhere at all. It's the latest update there is for board and I swear I don't see it in there anywhere at all. So entire thing is for not since you point out it must be turned off. How the heck to I do that when I can't find it. My plan is to turn it off, boot to disk drive with win 8 in it, delete entire drive(samsung 840 pro) then select format using GPT instead of NTFS. Then doing install of win 8, then back to bios turn on ultra fast boot and see what happens. But I can't get it done when I can't find the option in bios....

    Ok so I noticed you said disable fast boot. Ok I did that and yes now I see CSM. So in my plan, should I ..turn fast boot off, turn off CSM then put in win 8 disk in blu ray drive after making it the boot device in bios. I'm basically just want to make sure I get it installed in UEFI. But I can least sort things out now that I can see the option in the bios settings. Man this process is so beyond painful it's retarded.
    A UEFI installation process is really not that difficult, it is just not explained/documented very well, or at all anywhere.

    Yes, to install Windows 8 for UEFI booting you must set Fast Boot to Disabled. That will make the CSM option visible, as you know.

    Your plan to update for UEFI booting may have problems. Is Win 8 on the 840 Pro now, when you said "boot to disk drive", or is that a different drive? You cannot delete a Windows drive that you booted from.

    Check this guide about installing Windows 8 for UEFI booting: UEFI (Unified Extensible Firmware Interface) - Install Windows 8 with

    The only thing you do not need to do is enable Secure Boot, as that guide states. Just disable CSM and do not enable Ultra Fast boot until after Windows 8 is installed completely. Also, do not have any other drives connected (really connected to power) except the drive Win 8 will be put on, otherwise you will have problems later.

    Ultra Fast Boot only works when you start the PC from a cold boot/shutdown state. A reboot/restart does not use Ultra Fast boot. Do not disable Windows Hibernation, or Ultra Fast boot will not work.

  8. #8
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Ultra Fast Boot error

    Quote Originally Posted by hdtv00 View Post
    Ok so I have confirmed my disk version of win 8 does have efi files and folders on it. So I shouldn't need to make a usb boot non sense. Also now that fast boot is disabled under boot options I see my blu ray drive with win 8 in it listed as UEFI option under boot order so I should be good to go. Cept one thing I'm not entirely clear on is some places I see they say leave a partition 200MB at least but others I see it says to format GPD that you need to have drive only wiped with no partitions , I guess I could try it both ways first the 400MB that's already there left alone. Man I wish there were clear answers to all this, anyone feel free to help. THanks.
    You don't have to do anything, if the windows media has UEFI boot on it, all you do is pick boot from the media, pick UEFI from the menu to the media, windows will automatically format to GPT, when installing windows, and you're on the disk page, you will see three partitions, if you only see two, then it didn't install UEFI, and the one small partition is MBR.

    When booting, just pick F8, or what ever your boot option is to force boot, if you don't see UEFI choice for where the media is, then the correct file is missing from the media disk.



    @ PARSEC, hey bud, you beat me to it, rolol.
    Last edited by odiebugs; 10-27-2013 at 03:53 AM.

  9. #9
    Join Date
    Oct 2013
    Location
    USA
    Posts
    15

    Default Re: Ultra Fast Boot error

    well I'm in middle of it now. no I meant disk drive as in blu ray drive with win 8 in it, not my c drive. OK so issue I'm having now as I just now started to try this is it created the 4 partitions like it was gpt but now in win 8 its listed as NTFS still . but the biggest problem now is when I try and go into bios it shows up when I get in there but then goes black after a second and now I can't do anything options wise.....

    thanks so much for helping, I'm in middle of mess right now lol

  10. #10
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Ultra Fast Boot error

    Quote Originally Posted by hdtv00 View Post
    well I'm in middle of it now. no I meant disk drive as in blu ray drive with win 8 in it, not my c drive. OK so issue I'm having now as I just now started to try this is it created the 4 partitions like it was gpt but now in win 8 its listed as NTFS still . but the biggest problem now is when I try and go into bios it shows up when I get in there but then goes black after a second and now I can't do anything options wise.....
    Windows will make them when you boot UEFI. MBR and GPT, have nothing to do with NTFS, just because you are booting MBR or GPT, the disk is still NTFS.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •