Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Odd Question about a New Motherboard




  1. #1
    Join Date
    Oct 2013
    Location
    Australia
    Posts
    2

    Default Odd Question about a New Motherboard

    Hello everyone, my first post here, and I wish I had a better question, but I am waiting for my motherboard to come back from the shop.

    I was wondering if the CPU cover/protector, the little plastic guard over the CPU socket is Asrock branded or if they use Foxconn?

    I just bought a new Z87M Extreme 4 motherboard and it came with this foxconn branded cover over the cpu socket, is this normal?

    I would have thought they would have come with an Asrock branded cover.

    Thanks.

  2. #2
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Odd Question about a New Motherboard

    I don't consider it abnormal since Foxconn themselves most likely manufactured the CPU "socket' itself.

    Anyone else with an idea/postulation feel free to chime in.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    Join Date
    Oct 2013
    Location
    Australia
    Posts
    2

    Default Re: Odd Question about a New Motherboard

    Thanks wardog, was unsure as I just had to return the mobo due to the 1st. Pcie slot not working and was wondering if the board was really "new". Thanks for clearing that up for me.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •