Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Asrock 970 extreme4 too slow SSD speed




  1. #1
    dreamr is offline Junior Member
    Join Date
    Oct 2013
    Location
    kiev
    Posts
    4

    Unhappy Asrock 970 extreme4 too slow SSD speed

    Hello everyone. I bought kingston sv300s37a/120g SSD and pluged it to sata3_1 slot. Before installation windows i changed "sata mode" to AHCI from bios settings.


    Here is my test results and bios settings:
    Asrock 970 extreme4 too slow SSD speed-1-jpg

  2. #2
    Join Date
    Feb 2012
    Location
    Orlando, FL USA
    Posts
    15

    Default Re: Asrock 970 extreme4 too slow SSD speed

    It appears you are in AMDAHCI mode. Check out this thread Avoid AMD AHCI driver at all costs - AnandTech Forums . I have found that MSAHCI performs better in your system. To check your transfer mode (sata 300 or sata 600) run CrystalDiskInfo program. You should be getting 400+ reads and 200+ MB/sec writes on that drive.

    To verify drivers, go to Device Manager and look under the IDE driver and see what is installed. Uninstall the AMDSATA driver, restart your computer and let the system re-install MSAHCI drivers. I'm sure your drive will perform better! Good luck.

  3. #3
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock 970 extreme4 too slow SSD speed

    One thing I see in your BIOS screen shot, the "Aggressive Link Power Management" option. Set that to Disabled and never touch it again!

    My ASRock board won't even boot with a SSD for the OS when that option is enabled. Otherwise I have zero problems with my SSDs and my board. Having that option enabled would explain at least some of your poor performance in AS SSD.

    Next, your SSD uses a Sandforce SSD controller, which always scores lower in write scores when using AS SSD. That is normal and well known, since AS SSD uses all non-compressible data for its tests, the worst case for Sandforce based SSDs.

    Finally, I'm not sure about your SSD, but some earlier models used asynchronous NAND chips, which have poor performance in benchmarks. Your score looks like it does have asynchronous NAND, but I'm not sure.

    The AMD SATA driver (and SATA chipset) can have bad performance, but that seems to vary between boards.

    Try running the ATTO benchmark, download from here: Disk Benchmark | ATTO and post the results.

  4. #4
    dreamr is offline Junior Member
    Join Date
    Oct 2013
    Location
    kiev
    Posts
    4

    Default Re: Asrock 970 extreme4 too slow SSD speed

    Ok. I uninstalled AMD satadriver. Disabled "Aggressive Link Power Management"in bios. And here my results:

    Asrock 970 extreme4 too slow SSD speed-test-res-jpg

    In AS SSD i got worse results. For other programs i dont have any idea, waiting for your comments.

  5. #5
    dreamr is offline Junior Member
    Join Date
    Oct 2013
    Location
    kiev
    Posts
    4

    Default Re: Asrock 970 extreme4 too slow SSD speed

    CrystalDiskMark Test results:

    Asrock 970 extreme4 too slow SSD speed-cris-jpg

  6. #6
    Join Date
    Jun 2012
    Location
    usa
    Posts
    373

    Default Re: Asrock 970 extreme4 too slow SSD speed

    @ dreamr :

    ATTO confirms that in the high end your drive is achieving it's rated read & write. Every bench test is going to post different results, the kingston paired with the AMD controller is going to give a low result in asssd.

    Not always will the default micro driver give better results, better to run a test on both. If you went for a top SSD, you would see better assd result, but only in benching, in the real world, don't worry, there is little difference in real apps and gaming.

  7. #7
    Join Date
    Apr 2013
    Location
    boston ma
    Posts
    17

    Default Re: Asrock 970 extreme4 too slow SSD speed

    Quote Originally Posted by steveherdt View Post
    It appears you are in AMDAHCI mode. Check out this thread Avoid AMD AHCI driver at all costs - AnandTech Forums . I have found that MSAHCI performs better in your system. To check your transfer mode (sata 300 or sata 600) run CrystalDiskInfo program. You should be getting 400+ reads and 200+ MB/sec writes on that drive.

    To verify drivers, go to Device Manager and look under the IDE driver and see what is installed. Uninstall the AMDSATA driver, restart your computer and let the system re-install MSAHCI drivers. I'm sure your drive will perform better! Good luck.

    I find this very comical. I mean your refering to a article that was published over 3 years ago. I mean really. There has been a lot of changes since then. So it sounds like you dont even own the type of board and setup he does and your basing your facts on what other people said based on google searches. please...

    To the OP: I recomend enabling the feature for the AMD support, update your bios. Suggest using the drivers based on the 9xx series chipset from AMD which are newer. What version of windows. Disable prefetching, Superfetch, there is many things you can do. Need more info on the os. If your running windows 8 id suggest on triming the drive, i dont really believe in win7 auto trimining tbh i find this faulty and even win8. avoid defrags. Is the drive even formatted to the 4k? I had this drive you use.... just takes some configuring on the drive itself and the os. I also have the same board. But id update that bios looks like a old bios version. I dont use these drives no more switched to 2 samsung evo 840s. a lot better.

    My only gripe bout the AMD chipset hdd drivers is the raid doesnt support manual triming. But thats fine. And about the amd drivers being crap is pure crap someone going off a 3 year old article without any true facts.

    Look into also adjusting the cores of the processor which will have a effect on the drive as well, mainly if this is a win7 os. I find better support for win8.1 tbh.

  8. #8
    Join Date
    Feb 2012
    Location
    Orlando, FL USA
    Posts
    15

    Default Re: Asrock 970 extreme4 too slow SSD speed

    I find our forum troll and know-it-all phrozeng's reply very insulting. I'm just trying to help. As a matter of fact, I have an Asrock 990 Extreme4 board with a Kingston SSD which is pretty close to dreamr's setup. I got better results with MSahci than AMDahci as did dreamr. His SSD is not a great performer, but it is producing results as expected. My AS SSD score sequentials were 441 read and 106 write. The only thing further I can suggest is that some background programs or processes were running when you ran the AS SSD tests. Go into Task Manager and make sure you shut down all nonessential programs and processes while testing.

    Let's try to be helpful and not be so critical of others' suggestions.

  9. #9
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Asrock 970 extreme4 too slow SSD speed

    Quote Originally Posted by dreamr View Post
    Ok. I uninstalled AMD satadriver. Disabled "Aggressive Link Power Management"in bios. And here my results:

    Asrock 970 extreme4 too slow SSD speed-test-res-jpg

    In AS SSD i got worse results. For other programs i dont have any idea, waiting for your comments.
    Oh great, the results were worse, but it was worth a try.

    IMO, the ATTO results, which show speeds to specification, verify what I was afraid of. Your SSD has asynchronous NAND chips. I've seen this before in the OCN SSD forum, for Kingston SSDs. There is a thread in there somewhere, that your Kingston SSD model was manufactured in two places, and one of those used the asynchronous NAND chips, while the other location used synchronous NAND chips. Of course Kingston sent an example with synchronous NAND chips to the review web sites, which get much better results with AS SSD.

    ATTO uses all compressible data in its tests, which is the easiest type of data to deal with, particularly for SSDs with Sandforce controllers. That partially explains your poor AS SSD results. The asynchronous NAND chips is the other problem.

    You can read about asynchronous NAND in this thread: http://forums.tweaktown.com/storage-...rformance.html
    Last edited by parsec; 11-01-2013 at 11:25 AM.

  10. #10
    dreamr is offline Junior Member
    Join Date
    Oct 2013
    Location
    kiev
    Posts
    4

    Default Re: Asrock 970 extreme4 too slow SSD speed

    Oh fucckk.. You broke my heart Kingston, i will never buy anything from you anymore.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •