Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Reset Bios on ASrock z68pro3 gen3 Board




  1. #1
    Join Date
    Nov 2013
    Location
    Ireland
    Posts
    2

    Default Reset Bios on ASrock z68pro3 gen3 Board

    Hello,

    My PC crashed earlier and now my graphics card (nvidia gtx 680) is not being registered and has disappeared from my device manager. After some research it appears that resetting the bios may help. Could anybody tell me how to do that on the ASrock z68pro3 gen3?

    Any other advice on how to get my PC recognizing the graphics card again would be truly appreciated also., I have already unplugged and plugged it back in to no effect.

    Thanks a million.
    Last edited by longtimer; 11-04-2013 at 08:32 AM.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Reset Bios on ASrock z68pro3 gen3 Board

    Did you happen to try a newer Nvidia driver lately? Many users report problems with them, I'm able to use version 320 with my 760, but some users claim they must go back to 317 before things are stable. Newer drivers than 320 caused so much grief for me, couldn't even install them.

    If you have your board's manual handy, or download it from your board's information page on ASRock's website, you'll find the location of the CMOS/BIOS clear jumper, on page 13. It's at the bottom of the board, to the left of center. This is from your board's manual:

    Reset Bios on ASrock z68pro3 gen3 Board-bios-png

    The instructions don't tell you to remove the jumper that is already on pins 1 and 2, and move the jumper to pins 2 and 3. I'd wait for more than five seconds, a minute is fine. Then put the jumper back on its original position.

    Note that if you use any BIOS settings besides defaults, you will need to reset them after you do the BIOS clear.

  3. #3
    Join Date
    Nov 2013
    Location
    Ireland
    Posts
    2

    Default Re: Reset Bios on ASrock z68pro3 gen3 Board

    Thanks for the advice.

    I have reset CMOS now but to no effect unfortunately. I did recently install the newest driver for my graphics card but I've uninstalled everything now and still the card is not showing.

    ***EDIT***

    Graphics card has now appeared in device manager with a yellow triangle. I assume this means it needs drivers. I will install 320 and see how things go.

    Thank you so much for your help!
    Last edited by longtimer; 11-05-2013 at 10:58 PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •