Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Extreme4 z77 PCIE2 slot not working




  1. #1
    TreyWalker is offline Junior Member
    Join Date
    Nov 2013
    Location
    Minnesota, USA
    Posts
    1

    Default Extreme4 z77 PCIE2 slot not working (SOLVED)

    I just purchased an EVGA GTX 770 Classified, put it in slot PCIE2 as instructed by the instructions in the ASRock motherboard manual and the computer doesn't recognize it. It's like it is not there. I tried several times, making sure that it is seated well each time. As a debugging measure I put the GPU into the PCIE3 slot and it works just fine, but only at x8 (which was expected, that's why I am putting it into PCIE2, so that I can get x16).

    So, everything works great in PCIE3, but the computer doesn't recognize it at all when I have it in PCIE2. I am not getting any BIOS errors (I did at first, but those went away for some reason. I was getting 69) and the screen is just plain blank. When I plug into the motherboard video that comes up OK. When I look at the hardware it does not show the card (unless I move it back to PCIE3).

    System:
    Motherboard: ASRock Extreme4 Z77
    Motherboard BIOS Version: 2.90
    CPU: Intel Core i7-3770K
    GPU: EVGA GTX 770 Classified

    I tried to enter a ticket with ASRock on the website, but the message it gives me is "if you don't receive an automated email response then your message was not received." I didn't get an email (yes I checked SPAM, this was Saturday I believe). I tried again several times today, but still no automated email. I don't know how to contact ASRock to help with this, so I searched and came across this forum. Any help is appreciated.

    UPDATE #1: I was able to reach tech support through their Chino, CA office number. After speaking with the tech support we're doing an RMA. They were very nice and helpful, no hassle at all.

    UPDATE #2: As part of the diagnosis I found out that I had bad RAM as well. Before I pulled out the motherboard I wanted to know if it was the RAM or the RAM slots (assuming that the slots could be bad for RAM just like they were for PCIE2). Thorough testing showed that I had 1 bad stick of RAM and all RAM slots were good. Now if they repair the board instead of just sending a new one I don't have to worry about the RAM slots. HOWEVER, I felt inclined to run one more test. I kept the good memory stick in and moved the GPU back up to the primary PCIe slot (PCIE2). Amazingly it worked perfect! So, while ASRock was willing to give me an RMA, it appears that I won't need it. I'm going to run it a few more days just to make sure, but I find it amazing that a bad memory stick can cause a specific PCIe slot to not work. Very interesting indeed! Problem solved, now we can close this thread :-)
    Last edited by TreyWalker; 11-12-2013 at 03:38 AM. Reason: Added updates to status of situation

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Extreme4 z77 PCIE2 slot not working

    Thanks for posting this and the added information, all very important for others with a similar problem.

    IMO, it is just to simple to assume that a PCI-E slot doesn't work due to a bad DIMM. It's far more complex than that. The two things are related, but the needs of the video card also matters. A simpler device in that same slot might have worked, but would not have revealed the bad memory problem.

    You probably would have gotten a new (refurb?) board, since fixing one is not a simple procedure. The time and resources needed to fix a board can cost more than just replacing it. Plus a fix is not a guaranteed outcome of a repair attempt, after a several hour diagnosis by a highly paid technician reveals the board cannot be easily or cheaply repaired. So they send a replacement, and the money spent on the diagnosis is lost too.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •