Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 2 of 2 FirstFirst 12
Results 11 to 11 of 11

Thread: ESXi is not working on AsRock E3C226D2I Motherboard




  1. #11
    Join Date
    Mar 2014
    Location
    Edmonton, AB
    Posts
    1

    Smile Re: ESXi is not working on AsRock E3C226D2I Motherboard

    Quote Originally Posted by - wardog - View Post
    In just now looking back at this ASRock did post on the MB's BIOS download page an updated BMC file, revision 00.12.00 Dated Nov 13 2013.

    Maybe if SuperRed is still monitoring his thread they can respond if the latest BMC posted corrected for this.
    Hi.

    I know this is old thread but I'm going to post my solution in case somebody else is googling for an answer because i have a G3220 processor here and it freezes on IOV Initialization.

    I think this has to do something with how Asrock bios is configured ( since they officially support server processors ONLY on this board as far as i know )

    When you are at a black screen, just before the installer starts loading drivers but after the initial grub style loader ... Press SHIFT + O After that press SPACE, enter noIOMMU and press ENTER. ( you start typing near bottom, don't delete the runweasel command that's already there! if you do ESXi will boot instead of running the installer )

    This booted ESXi installer just fine for me :)

    After you install, do the SHIFT + O, SPACE and type noIOMMU during boot again to boot ESXi.

    Now, we have to make that noIOMMU setting persistent, but unfortunately that setting is not available via GUI so we gotta do some hacking.

    On the local ESXi console enable SSH and login as root using an SSH client like PuTTY. I had to go into Local Users and Groups under vSphere client and uncheck -> apply, check -> apply the option "grant shell access to this user" for the root user for me to be able to login.

    inside the shell, execute the command: esxcli system settings kernel set --setting=noIOMMU -v TRUE

    for some reason i had to do the esxcli procedure twice, when i rebooted the server the setting didn't persist... but tried it again and it worked. maybe the fact that i used the "sync" command on the console after i executed the above command helped ? i don't know.

    disable SSH, reboot your server and you are good to go !
    Last edited by reqlez; 03-28-2014 at 01:07 PM.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •