Specs:
OS: Windows 8.1 / Windows 7 Ultimate
CPU: Intel I7 3770k 3.9ghz Turbo Boost (Stock Speed)
CPU Cooler: Cooler Master Hyper 212 Evo
Mobo: Asrock z77 Extreme3 Bios 1.50
GPU: Evga GTX 670 4GB 04G-P4-2673-KR
PSU: Thermaltake SMART M Series SP-850M 850W / Antec EarthWatts EA650 650W (original PSU)
Mem: 16gb Corsair Vengeance CMZ8GX3M2A1600C9B (2 8GB Kits)
HDD: Western Digital Green WD10EARS 1TB 5400 RPM
DVD/CD: HP DVD Writer 1070r
CASE: Antec 900


This new build (about 6 months old now) has been giving me problems since day 1. Windows freezes randomly, I can be browsing the internet, gaming or idle. It even occurs sometimes when Windows is loading. The entire system becomes unresponsive and I have to do a hard reset. Until lately there has been no pattern to it. I honestly think I've tried everything at this point but here's an extensive list of what I have tried so far. At this point I'm convinced it's a compatibility issue regarding the motherboard...


1. Ran Memtest extensively. I started running it with all 4 sticks for about 12 hrs (not sure how many passes) with no errors. I then ran each stick separately, each for 24 hrs (again not sure how many passes it was) with no errors. And then after that, just because I was able to, I RMA'd the ram. I know the memory is not listed on AsRocks website compatibility list for this board but I have found it is compatible through my own research. I am also aware that running 2 different kits can produce errors, but I have tested 1 8gb kit (2x4gb) and it still freezes. I have tried 1 kit in a1 and b1 slots as well as a2 and b2 slots.
2. RMA'd the CPU. I have re seated the heatsink/CPU cooler numerous times (using Arctic Silver 5). At stock speeds (3.7 - 3.9ghz Turbo Boost)the temps run at about 34c idle & 60c full load in Prime95. I've tried overclocking and under clocking the CPU. I've got it to 4.4ghz at 1.18v. It ran at about 75c under load in Prime95 for 2hrs+ with no errors but will still freeze randomly. I've also ran it at 3.5 ghz at about 1.15v (60c under load) for several hours in Prime95.
3. RMA'd the motherboard. Initially I was running Windows 7 and I could recreate the freezing when installing the motherboards driver for the onboard LAN. So I figured the onboard LAN or driver might be to blame. But I have replaced the board, removed the driver and disabled the onboard LAN in the BIOS with the same result.
4. Ran extensive tests on the HDD with no errors. I replaced the SATA cables, tried using different SATA ports on the motherboard. I also tried replacing the HDD with an SSD.
5. Tired different GPU drivers. I always run the most current drivers, but I have also tried several previous versions as well as beta drivers. Replaced the GPU. I installed my GTX 280 from my previous build.
6. Replaced the PSU. Originally I had built this system with an Antec EarthWatts EA650 650W and replaced it with the Thermaltake 850M attempting to remedy the freezing.
7. Removed the HP DVD drive completely.
8. I am currently running the BIOS at default settings and with the current BIOS update 1.50. I've tried changing numerous settings in the BIOS. All of the BIOS changes were made individually and stress tested. I've tried downgrading the BIOS to previous versions (1.20). I have interchanged the all the DRAM settings. I have used the XMP profile. I have set the memory settings manually (9 9 9 24 2N & 1600mhz). I have run the memory at 1333mhz, which is what the board defaults it to without the XMP profile. I have set the ram voltage up 0.05v and down 0.05v. I changed the VTT, PCH and CPU PLL voltages small increments, up and down. I have tried the CPU LLC on every level from 1 to 5. I changed the BCLK from 100 to 100.1 and up to 101. I have turned off Intel SpeedStep, Turbo Boost, Smart Connect Technology & Rapid Start Technology. I have tried changing the CPU C States. With the C States disabled Windows will not boot, it will freeze during start up. I have disabled Intel HD graphics. I've tried disabling the serial port & the infrared port. I have tried disabling usb legacy 2.0 & 3.0 support. I disabled the USB 3.0 Controller. I've disabled onboard LAN, onboard HD audio & onboard HDMI audio. Honestly there are probably more thing I have tried changing in the BIOS but I can't think of them at the moment.
9. Replaced the mouse, keyboard & monitor. Swapped the monitor cables. Tried both DVI and HDMI.
10. Reinstalled Windows 7 numerous times. Upgraded to Windows 8.1. I have tried running with just the drivers that are installed with a fresh Windows install (Plug & Play drivers and drivers downloaded from Windows Update). I have gone through Device Manager and manually checked for updates for every driver in there.
11. I have tried several different methods for connecting to the internet by using the onboard LAN, a wireless PCI adapter & a wireless USB adapter.
12. I've tried unplugging the front USB panel from the motherboard (everything except the Power Button)
13. I ran Driver Verifier with all the non-Windows drivers selected, and did not get any BSOD's.
14. There isn't much in Event Viewer except for kernal power loss due to the hard resets.


My original guess was a hardware problem, due to the hard locking/freezing, but after replacing all the hardware my guess is either a BIOS setting, a motherboard compatibility issue or a driver issue. I have been troubleshooting this for what seems like forever, so I may have forgot to add something that I have already tried. At this point I'm about to give up and just junk this thing...Any help is greatly appreciated.