Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: B85M Pro4 - is PCIe x4 slot graphics only?




  1. #1
    Join Date
    Dec 2013
    Location
    Sweden
    Posts
    2

    Question B85M Pro4 - is PCIe x4 slot graphics only?

    I would also like an answer to this question (for B85M Pro4).
    Last edited by - wardog -; 12-04-2013 at 12:14 AM. Reason: Move post for exposure instead of hiding below another persons old post w a diff MB in question.

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Any PCI-E port can be used for any PCI-E device, they are not only for video cards.

    A PCI-E x 16 slot is required to use a video card, since it will only fit in that type of slot. But that does not mean those slots can only be used with video cards, they can be used with any PCI-E card, sound, HBA cards, NIC cards, etc.

  3. #3
    Join Date
    Dec 2013
    Location
    Sweden
    Posts
    2

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Ok. I just wanted to make sure that there were no unnecessary limitations in the BIOS, because of the wording in the manual and the fact that some people seem to have problems with the PCI-express slots on certain motherboards.

  4. #4
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Most times it's folks with Mini ATX boards that have only one PCI/PCIe slot that have problems with compatibility problems when inserting this or that NON-video card in it.

    With your board I can't foresee any difficulties. Of course, YMMV.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  5. #5
    Join Date
    Dec 2013
    Location
    Espoo, Finland
    Posts
    5

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    I actually got my B85 Pro4 few days ago and was planning to use ServeRAID BR10i RAID card with it. However, the card doesn't seem to register neither in x4 or x16 slot. It does work in another computer, so the card should be OK. It normally shows a configuration prompt during POST, but on B85 Pro 4 nothing. I'm running Debian and lspci doesn't show the card either.

    Any idea what could be wrong and how to fix?

    -JLarja

  6. #6
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    And the other PC that the RAID card worked fine in, has what for the OS?

    Check your BIOS, in the System Browser, to see if it is recognized.

    Try clearing the CMOS/BIOS, then reset your required settings and try again.

    Also in the BIOS, check for OROM display options, in the Boot screen. Turn off any Fast Boot setting.

  7. #7
    Join Date
    Dec 2013
    Location
    Espoo, Finland
    Posts
    5

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Ok, armed with the new information, I installed the card again. To my surprise, it worked on the first boot. I was able to enter card's configuration menu and later boot to Debian and check that the card was still there. So I shut down and connected couple of drives. This time card showed some error message (unfortunately I didn't write it down. It was something not very helpful along the lines "error in address 0xb1aab1aa", so it would only matter as something to google. After that the card was silent, no matter what I did, so my guess is that it is probably broken after all. The previous test on another computer was a short one. I just put the card in, booted, checked the card's configuration menu, booted to OS (Windows 7) and checked that the card was visible there.

    I did try disabling network option ROMs, but that didn't help. It also seems that the card should be visible in OS even if the option ROM fails to run. I tested with two other SATA cards and both worked just fine even when I disabled all legacy option ROMs (my god the boot was fast that way. I'm almost sorry that it is an always on server). Good thing is that x16 and x4 slot do seem to work for other than graphics cards, so I just need to find a good SATA card.

    I'm probably going to forget about port multipliers. I don't know if anyone actually sells them in Finland and considering the uncertainty of whether they will work at all and the extra cost of ordering from abroad, the value isn't really there.

    Thanks for your help.

    -JLarja

  8. #8
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Two things to consider.

    1. Have you tried disabling the on-board SATA controllers in the MB's BIOS and then seeing if the card shows up and funtions?

    2. Is the card still flashed IR(RAID)? If so and you won't require RAID, that card, like my M1015's, can be flashed IT(Passthrough, non-RAID). Not your BR10i, but the M1015's, IT mode has solved many a problem with recognition issues. I know, if you can't now see the card just how the heck do you flash it. Find a computer that does recognize it and enter the commands VERY CAREFULLY AND CORRECTLY to flash it to IT.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  9. #9
    Join Date
    Dec 2013
    Location
    Espoo, Finland
    Posts
    5

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    Quote Originally Posted by - wardog - View Post
    Two things to consider.

    1. Have you tried disabling the on-board SATA controllers in the MB's BIOS and then seeing if the card shows up and funtions?

    2. Is the card still flashed IR(RAID)? If so and you won't require RAID, that card, like my M1015's, can be flashed IT(Passthrough, non-RAID). Not your BR10i, but the M1015's, IT mode has solved many a problem with recognition issues. I know, if you can't now see the card just how the heck do you flash it. Find a computer that does recognize it and enter the commands VERY CAREFULLY AND CORRECTLY to flash it to IT.
    Ok, I'll try that. I didn't think changing to IT firmware would matter, but since I don't need (and don't want) to use RAID, I'll give it a shot. Hopefully the card will work on Windows 7 computer like it did before. I'll try disabling on-board SATA, if necessary. Could be few days though, I'll post here again then.

    -JLarja

  10. #10
    Join Date
    Dec 2013
    Location
    Espoo, Finland
    Posts
    5

    Default Re: B85M Pro4 - is PCIe x4 slot graphics only?

    So I flashed the card and got it running. However, it seems that the real problem was simply bad contact between the card and PCIe slot. I had originally fastened the card in place in my server. When I tested it on Windows desktop, I was lazy and simply plugged the card in. Turned out that if the card is fastened to place tightly, it may show up but show the error message, or not show up at all. Pushing the card few millimeters, so it's not completely perpenticular in respect to the motherboard, helped. As the card is installed vertically to server while horizontally to desktop, it was quite natural that it hardly ever worked in the server and almost always in desktop. Luckily, I was able to fasten the card to the server in such a way that it works and isn't overly unstable.

    I don't completely trust the setup, but as the card only supports disks up to 2 TB, it won't have that many years left anyway.

    -JLarja

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •