Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 2 of 2

Thread: Extreme6/ac BIOS corrupted




  1. #1
    Join Date
    Dec 2013
    Location
    United States
    Posts
    1

    Default Extreme6/ac BIOS corrupted

    I tried to update my Extreme6/ac BIOS from 2.10 to 2.20 from Windows (as administrator) and from within the UEFI. Both failed. Starting in Windows, on reboot the screen froze on the ASRock BIOS screen and an A2 error code in Dr Debug. Switched to BIOS B and restored BIOS A successfully to 1.40.

    I tried updating from within the UEFI - the file section showed the BIOS 2.20 file name but then quickly changed the displayed file name to "config.sys" and froze. I could do nothing but reboot. I could see no config.sys on my flash drive and even tried reformatting it but the UEFI still quickly switched to showing config.sys and froze. In no case could I actually start a BIOS update within the UEFI because I could not actually select the BIOS name to start the update.

    Switching to BIOS B, I tried again to update from within Windows (thinking it would update BIOS A and knowing that BIOS B was protected). Now, both BIOS A and BIOS B freeze on the ASRock BIOS screen with an A2 code. I have tried unplugging the power, switching back and forth, and leaving it on the frozen ASRock screen for six hours.

    I now see the A2 code means an IDE or SATA error (I don't have any IDE drives and I didn't change anything with my SATA drives or connections).

    What to do to restore my BIOS?

  2. #2
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Extreme6/ac BIOS corrupted

    I just updated my Z87 EX 6 board (not ac version) to version 2.20 using Instant Flash, and it worked perfectly, using that PC now.

    Why do they keep providing the Windows BIOS update option... they seem so prone to failure, I'd never and don't use that option.

    The behavior you had when trying Instant Flash is strange, I've never seen that happen. I must say that option's screen is touchy, the Configure and Refresh buttons seem to activate if the mouse pointer even touches those buttons.

    I would try a hard CMOS/BIOS clear. Power off, use CMOS clear jumper on the board, and remove the battery for five minutes. Set the BIOS switch to A after that.

    Start the PC and hopefully get into the BIOS, and see what version you have. Find and select the Load UEFI defaults option, and restart into the BIOS again. If you need any BIOS settings like RAID, set those and try to boot into Windows.

    Instant Flash is the only BIOS update method I recommend. Are you using your mouse in the BIOS? Keyboard maneuvering might activate unintentional choices in Instant Flash.

    Try downloading and unzipping another copy of BIOS 2.20, and put the USB flash drive in one of the USB 2.0 ports on the board's I/O panel.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •