Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 3 of 3

Thread: Z77 Extreme 4-M + R9 270X not recognized?




  1. #1
    Join Date
    Dec 2013
    Location
    USA
    Posts
    2

    Default Z77 Extreme 4-M + R9 270X not recognized?

    Same issue as described here

    Can get to boot from the onboard video but every time I try and install the drivers for the 270X it blanks all display output.

  2. #2
    Join Date
    Dec 2013
    Location
    USA
    Posts
    2

    Default Re: Z77 Extreme 4-M + R9 270X not recognized?

    Magically worked from Friday to last night when I shut it down. Turn it on today to the same issue. Tried newest bios, and everything else has been rock solid until now.

    Anyone else having these compatability issues?

  3. #3
    JeffKrueger is offline Junior Member
    Join Date
    Jun 2014
    Location
    Waukesha, WI
    Posts
    2

    Angry Re: Z77 Extreme 4-M + R9 270X not recognized?

    Yes, I'm having the same problem with ASRock Z77 Extreme4 MB (w/ BIOS P2.90) & R9 270X video card.
    I tried the following:
    • R9 270X video card in different computer (video card then works)
    • PCIE2 & PCIE3 slots (no video output on R9 270X)
    • Clearing CMOS (no video output on R9 270X)
    • Setting PCIE link speed to Auto, Gen1, Gen2, Gen3 (no video output on R9 270X)
    • Setting 'IGPU Multi-Monitor' to 'Disabled' (no video output on R9 270X)
    • monitor only connected to MB (MB DVI output works)
    • monitor connected to either DVI connector on R9 270X (no video output on R9 270X)
    • monitor connected to MB & additional monitor connected to R9270X (MB video works, no video output on R9 270X)
    • measured 2 additional power connectors on end of R9 270X (all yellow at 11.95V relative to black)
    Jeff

    Motherboard: ASRock Z77 Extreme4 w/BIOS V2.90
    Processor: Intel i5-3570K Ivy Bridge 3.4GHz Intel HD Graphics 4000
    RAM: G.SKILL Ripjaws X Series DDR3 1600 (8GB x 2)
    Video card: PowerColor PCS+ AXR9 270X
    Power supply: RAIDMAX Cobra RX-500AF-B 500W ATX
    Monitor: Acer G6 Series G246HLAbd Black 24"
    OS: Microsoft Windows 7 Home Premium SP1 64-bit
    Overclocking: none

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •