Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: ASrock Mobo not going into BIOS: Plase Help!




  1. #1
    Rok125 is offline Junior Member
    Join Date
    Dec 2013
    Location
    Powder Springs, GA
    Posts
    5

    Default ASrock Mobo not going into BIOS: Plase Help!

    Hello, first time assembling a complete build, and I would very much appreciate some help.

    In my system I have
    i5-3570K
    ASRock Z77M Micro ATX
    G.Skill Sniper Series 8GB
    Samsung 840 Series 120GB
    Cannibalized laptop HDDs: Samsung 320Gb & WD Blue 250Gb
    SeaSonic 620W
    BitFenix Prodigy MicroATX


    All fans spin, PSU is on, and HDDs are buzzing. I get to the splash screen and that's it. I press f2, f6, and delete to get to the BIOS and nothing. I wanted to see if its taking a signal from my keyboard so I tried ctrl+alt+delete and the pc resets.

    I have tried:
    all three of the graphic ports
    taking out the motherboard battery and power and waiting 10 minutes.
    booting with just the SSD to see if the HDDs were doing something to the config
    and using only 1 dimm (tried both dimms one at a time on both dimm slots)

    all these came out to the same result. Splash page that doesn't let me into the BIOS.
    Any ideas?
    Thanks in advance for any replies.

  2. #2
    ajcroteau is offline Junior Member
    Join Date
    Dec 2012
    Location
    A, A
    Posts
    7

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Have you tried running the ASRock Restart to UEFI Application? That's how i get into the BIOS most of the time...

    - AJ

  3. #3
    Rok125 is offline Junior Member
    Join Date
    Dec 2013
    Location
    Powder Springs, GA
    Posts
    5

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by ajcroteau View Post
    Have you tried running the ASRock Restart to UEFI Application? That's how i get into the BIOS most of the time...

    - AJ
    No, I haven't done this. I'll google how to do this. However, if you can point me to a link so that I can do this I will give it a try, and report back if there has been any change.

    I can't get the computer to show me anything except for the splash screen. Should I flash the BIOS with the 1.70 version found at this link
    http://www.asrock.com/mb/Intel/Z77M/...nload&os=BIOS?
    Last edited by Rok125; 12-16-2013 at 05:17 AM. Reason: To add to the response

  4. #4
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by ajcroteau View Post
    Have you tried running the ASRock Restart to UEFI Application? That's how i get into the BIOS most of the time...
    This would be impossible since they can't get by the splash screen at POST, never mind Restart to UEFI. That, and I don't believe this MB even has the option available.

    OP, what's the model of those G.Skill Snipers?

    Reseat both 8pin and 24pin power leads to the MB.

    I read you pulled the battery but did you jumper the CLR CMOS jumper for 10mins also while the battery was out? Do this with the PSU disconnected from the wall
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  5. #5
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by Rok125 View Post
    Should I flash the BIOS with the 1.70 version found at this link
    ASRock > Z77M
    No!

    1. You don't have the opportunity to flash as it stops at the splash screen.
    2. More importantly, NEVER flash the BIOS of a system that is not stable.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  6. #6
    Rok125 is offline Junior Member
    Join Date
    Dec 2013
    Location
    Powder Springs, GA
    Posts
    5

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by - wardog - View Post
    This would be impossible since they can't get by the splash screen at POST, never mind Restart to UEFI. That, and I don't believe this MB even has the option available.

    OP, what's the model of those G.Skill Snipers?

    Reseat both 8pin and 24pin power leads to the MB.

    I read you pulled the battery but did you jumper the CLR CMOS jumper for 10mins also while the battery was out? Do this with the PSU disconnected from the wall
    These are my GSkills
    G.SKILL Sniper Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1866 (PC3 14900) Desktop Memory Model F3-14900CL9D-8GBSR - Newegg.com

    I didn't do the CLR CMOS jumper for 10 mins.

    <strikethrough>Should I unplug the psu, take out the battery and do the CLR CMOS jumper, for 10 mins?</strikethrough>
    Never mind, I'm doing this now
    Last edited by Rok125; 12-16-2013 at 06:15 AM. Reason: update

  7. #7
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by Rok125 View Post
    ... unplug the psu, take out the battery and do the CLR CMOS jumper, for 10 mins?
    Yes, that is the correct sequence. Then reverse them to put everything back.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  8. #8
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    I don't foresee that memory, assuming you don't have two bad sticks(heaven forbid!), as causing this.

    I'm hoping you'll come back and post that clearing the CMOS the way I mentioned solves this for you.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  9. #9
    Rok125 is offline Junior Member
    Join Date
    Dec 2013
    Location
    Powder Springs, GA
    Posts
    5

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    Quote Originally Posted by - wardog - View Post
    I don't foresee that memory, assuming you don't have two bad sticks(heaven forbid!), as causing this.

    I'm hoping you'll come back and post that clearing the CMOS the way I mentioned solves this for you.
    I did the CMOS reset and it worked. However, it was because in disconnecting everything I disconnected my keyboard.
    Now if I reset and the keyboard is in, the splash page comes up and stays there again.
    However, if I disconnect the keyboard and reset it. Then I get
    "Reboot and Select proper Boot device, or Insert Boot Media in selected Boot Device and press a key."

    If I plug in the keyboard and press any key then it repeats the above line.
    I use my brother's keyboard and this problem doesn't arise. So It's something to do with my logitech keyboard.
    It seems I tripped over the solution. Have you heard of anything like this?
    I take it that its ready for me to upload the OS. Right?

  10. #10
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: ASrock Mobo not going into BIOS: Plase Help!

    You're using a gaming or other advanced functions keyboard then, right?

    If so, then yes that [/i]could[/i] be the problem.

    From here anyways I'd say you're good to go. Possible keyboard problem being an exception.
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •