Please report all spam threads, posts and suspicious members. We receive spam notifications and will take immediate action!
Results 1 to 8 of 8

Thread: Z77 Exreme 4 not booting




  1. #1
    Join Date
    Dec 2013
    Location
    Chicago
    Posts
    4

    Default Z77 Extreme 4 not booting anymore after power surge

    My computer was working fine for a year until I had a minor power surge which rebooted my system. I had a surge protector in place, but when the reboot happened the only thing that powers on are the fans for the processor and the case. The reset and power buttons on the motherboard do work, but the Dr. Debug display doesn't show anything, as if the display isn't working anymore. There are also no beeps or noises to alert me of anything, and I'm not getting any video either to see the BIOS. The power button on the case works, but the reset button doesn't.

    I also removed the video card and unplugged the HDs from the motherboard, and connected the monitor to the DVI port that's built in, still nothing.

    Does anyone have any solutions as to what I can try to fix my problem? Thanks.
    Last edited by adamzeliasz; 12-28-2013 at 11:12 AM.

  2. #2
    Join Date
    Nov 2012
    Location
    USA
    Posts
    2,675

    Default Re: Z77 Extreme 4 not booting anymore after power surge

    Quote Originally Posted by adamzeliasz View Post
    The reset and power buttons on the motherboard do work, ..

    .....

    The power button on the case works, but the reset button doesn't.
    Hello and welcome to TweakTown. Even if it is under this circumstance.


    While unplugged from the wall and after waiting 1 minute pull the cases Reset wires/plug off the MB's system panel header, press the CLR CMOS at the rear I/O panel, connect power back and retry.

    After doing the above, did you notice ANY changes from before?
    #1 - Please, when seeking help, enter the make and model of ALL parts that your system is comprised of in your Signature, or at least the model #'s in your System Specs, then "Save' it.
    ____If you are overclocking, underclocking, or undervolting any parts, informing us of this and their values would prove beneficial in helping you.

    #2 - G.Skill RAM Configurator for your boardSamsung Memory for your boardLatest AMD Chipset Drivers/WindowsLatest AMD Graphics Drivers/WindowsLatest Intel Drivers

    #3 - Please use the eXtreme Outer Vision Power Supply Calculator found HERE to determine if it might be your PSU at issue.
    ____Consider your PSU to be the foundation from which all else is built upon. Anything built upon a weak foundation is poorly built.

  3. #3
    Join Date
    Dec 2013
    Location
    Chicago
    Posts
    4

    Default Re: Z77 Extreme 4 not booting anymore after power surge

    Quote Originally Posted by - wardog - View Post
    Hello and welcome to TweakTown. Even if it is under this circumstance.


    While unplugged from the wall and after waiting 1 minute pull the cases Reset wires/plug off the MB's system panel header, press the CLR CMOS at the rear I/O panel, connect power back and retry.

    After doing the above, did you notice ANY changes from before?
    Still nothing. Its pretty much bare bones now... just a power source, monitor hooked to the on-board DVI. I would think the BIOS would at least come up. The Dr. Debug panel should display something or at least light up, correct? I'm only getting the fans turning on the CPU. There isn't any beeps either.

    Could it be a battery issue? Can anyone chime in on dust particles? I haven't blown it out in a while, so I wasn't sure if that could have been a factor.

    I have a feeling that the motherboard may have blown out. Does anyone know if it's worth the hassle of trying to have ASRock look at it under their 3 year limited warranty, or should I just buy another? I never had motherboard issues so I have no idea what the cost/time frame would be on a repair job...

  4. #4
    Join Date
    Dec 2013
    Location
    Chicago
    Posts
    4

    Default Re: Z77 Exreme 4 not booting

    Computer specs below
    SPECS:
    ASRock Z77 Extreme4 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
    Intel Core i7-3770 Ivy Bridge 3.4GHz (3.9GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor
    G.SKILL Trident X Series 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC3 19200) Desktop Memory Model
    Kingston HyperX 3K SH103S3/120G 2.5" 120GB SATA III MLC Internal Solid State Drive (SSD) (Stand-Alone Drive)
    GIGABYTE GV-N65TOC-2GI GeForce GTX 650 Ti 2GB 128-bit GDDR5 PCI Express 3.0 x16 HDCP Ready Video Card
    LITE-ON Black 12X Blu-ray Burner with Blu Ray 3D Feature SATA IHBS112-04 - OEM
    OCZ ModXStream Pro 700W Modular High Performance Power Supply
    Lian Li PC-B25F case

  5. #5
    parsec's Avatar
    parsec is offline Senior Member
    Join Date
    Jun 2012
    Location
    Third stone from the sun
    Posts
    4,824

    Default Re: Z77 Exreme 4 not booting

    Since the first thing in the path of any power surge is the PSU, that needs to be checked first.

    The best test would be trying another PSU in that PC, and see what happens.

    An electrical surge that reaches a mother board could randomly damage any number of parts on the board, there is really no way to predict (or expect) what will work and what won't. The BIOS won't run if the CPU is not operating, or if the memory is damaged and not working. If the video source was damaged, without output to the monitor could you know if the BIOS interface was running or not?

    Hopefully the PSU gave its life to save the rest of the PC, if you are lucky.

  6. #6
    Join Date
    Jan 2014
    Location
    Palestine
    Posts
    10

    Default Re: Z77 Exreme 4 not booting

    I have exactly the same Problem with the same MB
    I just post a new post in this fourm
    http://forums.tweaktown.com/asrock/5...ck-z77-x4.html
    Plz , if you solve the problem , contact me on my FB
    https://www.facebook.com/Mohammed.F.Radi

  7. #7
    Join Date
    Dec 2013
    Location
    Chicago
    Posts
    4

    Default Re: Z77 Exreme 4 not booting

    Quote Originally Posted by Mohammed F Radi View Post
    I have exactly the same Problem with the same MB
    I just post a new post in this fourm
    http://forums.tweaktown.com/asrock/5...ck-z77-x4.html
    Plz , if you solve the problem , contact me on my FB
    https://www.facebook.com/Mohammed.F.Radi
    It turned out that it was my power supply which needed replacing.
    SPECS:
    ASRock Z77 Extreme4 LGA 1155 Intel Z77 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard
    Intel Core i7-3770 Ivy Bridge 3.4GHz (3.9GHz Turbo) LGA 1155 77W Quad-Core Desktop Processor
    G.SKILL Trident X Series 16GB (2 x 8GB) 240-Pin DDR3 SDRAM DDR3 2400 (PC3 19200) Desktop Memory Model
    Kingston HyperX 3K SH103S3/120G 2.5" 120GB SATA III MLC Internal Solid State Drive (SSD) (Stand-Alone Drive)
    GIGABYTE GV-N65TOC-2GI GeForce GTX 650 Ti 2GB 128-bit GDDR5 PCI Express 3.0 x16 HDCP Ready Video Card
    LITE-ON Black 12X Blu-ray Burner with Blu Ray 3D Feature SATA IHBS112-04 - OEM
    OCZ ModXStream Pro 700W Modular High Performance Power Supply
    Lian Li PC-B25F case

  8. #8
    Join Date
    Jan 2014
    Location
    Palestine
    Posts
    10

    Default Re: Z77 Exreme 4 not booting

    Quote Originally Posted by adamzeliasz View Post
    It turned out that it was my power supply which needed replacing.
    I have replaced the PSU , but that doesn't make any difference !!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •